Still experiencing issues on RDP 10.7.5 on macOS with multiple monitors

Still experiencing issues on RDP 10.7.5 on macOS with multiple monitors
0

Upvotes

Upvote

 Jan 27 2022
9 Comments (9 New)
Tell us more

After experiencing the known issues on 10.7.4 I had to roll back to an old version. Today, after seeing that version 10.7.5 (1969) was released I updated RDP and sadly it is still broken for me.

 

macOS 12.1

MBP 16" M1 Max

RDP 10.7.5 (1969)

Support ID: 58AD2D3D-F6A7-4DE8-A68B-C55095583EF8

 

I have to external monitors, one positioned above the primary and one positioned to the left of my primary.

 

Primary:

Primary ScreenPrimary Screen

 

Screen to the left of primary:

Third screen (located to the left of primary)Third screen (located to the left of primary)

 

Screen above primary:

Secondary screen (located above primary)Secondary screen (located above primary)

Comments
Microsoft
Status changed to: Tell us more

Hi @edgariscoding ,

As I reached out in the other thread, a screenshot of your screen arrangement will be helpful for repro - thanks!

Established Member

@JS 

 

Sure here's a screenshot:

 

Screen Shot 2022-01-30 at 9.28.28 PM.png

 

And what I'm experiencing is Remote Desktop not using all 3 of my monitors. It only uses the primary monitor and it is at a low resolution.

Microsoft

@edgariscoding 

Is the monitor located above the two lower monitors a 4k monitor? Also, do you have Connection Settings (if connecting through bookmarks you can navigate to display setting) setting turned on/off for retina display? Try turning it off to see if that helps, also trying other configurations will help us understand what the issue is. 

Established Member

@JS Yes it's a 5K LG UltraFine 27". I do have the setting turned ON for Retina display. I can try changing it after work.

Established Member

@js351 Yes it's a 5K LG UltraFine 27". I do have the setting turned ON for Retina display. These are my current settings that worked fine:

Screen Shot 2022-02-02 at 11.22.35 AM.png

 

and this is what it looks like after connecting when I try v10.7.4 or v10.7.5:

 

IMG_4877.jpg

 

Disabling "Optimize for Retina Displays" seems to fix part of the issue and I'm able to use all three monitors. I can definitely tell that text/images are a bit fuzzy on my displays though.

 

My displays:

Built-in Liquid Retina XDR Display on 16" M1 MacBook Pro (3456px x 2234px) - center

LG UltraFine 5K 27" (5120px x 2880px) - above

Dell P2211H 21.5" (1920px x 1080px - left

Microsoft

Hi @edgariscoding ,

Thank for you the detailed response - we will need to emulate this set up for a dev to repro and investigate the bug. In the meantime, the recommendation will be to disable the retina displays, we will keep you updated on the patch and apologies for the inconvenience 

Regular Visitor

I also have the same resolution issue as @edgariscoding.

 

MacBook Pro 16 2019 (Intel).

 

Here is my layout:

balansse_1-1644854179699.png

Monitors above MacBook screen are 4K LG monitors connected using Thunderbolt.

Both external monitors use the same settings:

balansse_6-1644854378295.png

 

Found a workaround - decreased the resolution on the built-in Retina screen a little:

balansse_0-1644853899608.png

Now RDP connects fine but the display layout during RDP connection is broken:

Untitled.jpg

 

 

Mouse pointer moves correctly but dragging windows between monitors becomes very confusing.

 

Can this be fixed or adjusted?

 

Microsoft

Hi @edgariscoding @balansse,

We appreciate the detailed feedback here and apologize for the issue. In the meantime, we recommend experimenting with display arrangements and resolutions that do not cause buggy behavior.  

Established Member

@js351 I will just continue using v10.7.3 which worked perfectly fine. I don't really want to have to change my work environment to accommodate a buggy app. If @balansse or anyone else needs the older app let me know.