Issue with Microsoft Remote Desktop for Mac

Issue with Microsoft Remote Desktop for Mac
1

Upvotes

Upvote

 Dec 27 2021
7 Comments (7 New)
New

With the latest update for Microsoft Remote Desktop for Mac, version 10.7.3, we are not able to successfully connect to her work computer. We had assistance with her employer's IT service desk, and they stated there is an issue with the computer connecting to the network. The settings were confirmed to be correct and we are using the same settings on her PC. This is very frustrating and disrupting her ability to work from home at times. Any suggestions to resolve the issue would be greatly appreciated.

Comments
Frequent Visitor

I am having the same issue. Other users in our workplace who have not updated to the latest version are not having connection issues and are able to work. Very frustrating. I also would appreciate suggestions to resolve. The RDP needs to be updated or needs to be reverted back to prior versions until this one can be remedied. I will be turning off the auto-update feature for apps from the AppStore on my Mac to prevent this from happening again.

Regular Contributor

I believe this is being worked on by the Microsoft Engineering teams, using a previous version of the agent is the workaround at the moment.

Occasional Visitor

I'm having the same issue.  worked perfectly until the latest update.  How do you go about installing the previous version?  

 

Regular Contributor
Microsoft

@Luke Murray  Thank you for the assistance on the thread. And yes the engineeringteam is working on a fix for this regression, apologies for the inconvenience @amerkes1989 @Nancy_Squires

Occasional Visitor

i just installed the beta and it does not work either

 

Occasional Visitor

Hello all.  I'm new here but wanted to register a very strange issue I'm having with RDP on M1 Mac. 

This seems to be a VERY specific issue just on M1 with the latest 10.7.7 or 10.7.6 RDP.  Even the Beta displays the same exact issue.  Error 0x4 when connecting to a Windows 10 Virtual Machine.  We have VMware 7.0.3.x in our environment.  

 

I can RDP to any VM in our cluster without issue on an intel based Mac.  We have several hosts running virtual machines and when on an intel Mac.  I can connect to any VM perfectly from an intel based Mac.  When we try with an M1 based Mac.  It will also work, but not on 1 host.  These hosts are configured exactly the same as each other.  Same versions of the OS, network, etc.  

Only the M1 on one specific host, it will display an error 0x4 when connecting to VM's that work perfectly on any other host in the cluster.  

 

This is baffling to say the least.  Again, with the beta and the most currently RDP release.  

I don't even know whom to contact for this issue.