Can't copy and paste between Microsoft Remote Desktop and other macOS apps

Can't copy and paste between Microsoft Remote Desktop and other macOS apps



 May 19 2022
7 Comments (7 New)

For the last couple days (since upgrading to macOS 12.4, although I don't know whether this is related) I can no longer copy and paste between my remote computer on Microsoft Remote Desktop and other macOS apps. The remote desktop and my Mac appear to be keeping separate clipboards.



1. In Microsoft Remote Desktop, in an email message, right-click a link.

2. Choose Copy Hyperlink

3. In Safari on Mac, click in the location bar

4. Cmd-V to paste


Expected result: Paste hyperlink copied in step 2

Actual result: Either the paste fails (clipboard empty) or I paste whatever I last copied in some other app than Microsoft Remote desktop


5. Select some text in Safari

6. Right-click and choose Copy

7. In Microsoft Remote Desktop, in the remote Windows computer, Ctrl-V to paste


Expected result: Paste text copied in step 6

Actual result: Paste text copied in step 2


My workaround is to use OneDrive, Notepad on Windows, and TextEdit on Mac to pass information between the two environments.


P.S. I was brought to this current page by, in Microsoft Remote Desktop, choosing Help > Submit Feedback, so I would guess this is the right place. However, I see at the right, "If you have a technical question or need product support, please use Microsoft Q&A. Tech Community should be used for general discussions, how-to’s, best practices, and connecting with fellow community members using Azure." However, that link goes to a page that has no way to seek help for Microsoft Remote Desktop, only for Azure. You might want to update either where Microsoft Desktop's Help > Submit Feedback or else that link at the right on this page goes.


Also, I keep getting messages to correct the highlighted errors. The highlights are too subtle and I have to hunt for them.

Steel Contributor

Hi @Charles_Belov ,


Have you checked if the Clipboard is enabled in your Microsoft Remote desktop client?


Open Microsoft Remote desktop, right click on the Icon (computer you remote in) > Edit >under Devices & Audio > make sure Clipboard is checked. You can re-check it if it is and try.







If this is not an issue, try remove the app and re-install. 



Copper Contributor

Thank you. I checked it and Clipboard was checked. The function previously worked 98% of the time, and it's working today, so I'm guessing its a (dreaded) intermittent bug.

Steel Contributor

@Charles_Belov that is a great news!

Copper Contributor

In my case the clipboard mode is disabled (for workspaces) to select another option.
What should I do?




Copper Contributor

In the version of Remote Desktop Web client (Version used by the organization I remotely connect to, there are no options to enable or disable clipboard transfer. (In fact, there are no useful options for users at all!) PATHETIC

Copper Contributor

What worked for me was killing the rdpclip.exe process running in the remote machine and running it again, the process described in this page:

Copper Contributor

@maumoura really helpful, killing rdpclip.exe worked for me as well... reinstall restart nothing else worked