Adding a Workspace on Microsoft Remote Desktop

Adding a Workspace on Microsoft Remote Desktop



 Oct 06 2022
4 Comments (4 New)

I am unable to add a workspace.  It tells me the workspace isn't a valid URL.  It works on older versions of Remote Desktop.

Copper Contributor

On Mac, I get the error, on Windows 11 rds client, it accepts the endpoint and displays our AVDs.


Trying to subscribe to our AVDs in Azure.  I try to subscribe via URL:

However, it results in problem:
“No workspace is associated with this URL”


On my Win11 PC it works.


This is such a basic function.  Sometimes I have suspicions that Microsoft intentionally breaks stuff on the Mac for competition sake.  Or, Microsoft really releases code this buggy by accident or carelessness?  Is there a third option?  Did I enter something incorrectly?

Copper Contributor
The error message "workspace isn't a valid URL" suggests that there may be an issue with the information you're entering for the workspace. When adding a workspace in Microsoft Remote Desktop, it's important to enter the correct information in the required fields. Here are a few steps you can try to resolve this issue: Check the format of the URL or resource name: Make sure that you're entering the correct format for the remote resource or remote PC name, as specified in the MRD documentation. Verify the connection information: Ensure that the connection information you've entered is correct, including the remote PC name, IP address, or resource URL. Update MRD to the latest version: If you're using an older version of MRD, try updating to the latest version to ensure that you have the latest features and bug fixes. Reset MRD: If updating MRD doesn't resolve the issue, try resetting the app to its default settings. To do this, go to Settings > Accounts > Reset, and then follow the prompts. If these steps don't resolve the issue, you may want to seek further assistance from Microsoft support or through the Microsoft community forums.
Copper Contributor

On my Mac, I had been using the officially released RDS client from the Microsoft store between Oct 2022 and mid-Jan 2023.  It accepted the workspace URL that worked on the Win11 PC.  Then I connected to a local PC via its Local lan IP.  That would not connect.  Ugh.  
So I uninstalled it and I installed the RDS Beta mid-Jan 2023.  Voila; I could now connect to my PC via RDP on its local lan IP.  But now I cannot subscribe to an AVD feed because it doesn’t like the workspace URL (as described in my original post above). 
Please note carefully:  (a) I copied the URL via Ctrl-c, Ctrl-v from notepad to both the Win11 and Mac RDS clients and (b) visually inspected all results of the copy/paste in all attempts for sanity check.  I’ve worked in IT for 39 years and recognize URL paths, UNC paths and many endpoint format types like math professors recognize quadratic equations.  I assure you there is no mistake in what I am entering as the workspace URL.  This software is BROKEN.  Microsoft; please consider the numerous duplicate postings about the issues with the Mac RDS client, do not blame the users, and instead recognize the poor quality of this software.  Please stop punishing us with this stuff that doesn’t do the basic function it is built to do.  We pay a lot for our Azure AVDs every month and we should be able to reach them from the clients you promised.  Now from my Max I must RDP to a Win11, then from Win11, I RDS to the AVD.  Ridiculous.

Copper Contributor

I had the same issue. I tried to find a version of RDS Beta that works. I have tried a lot of versions and it seems like the latest version that works for me is 2022 August - (Version 10.7.9). The next version (10.8.0) and following don't work anymore and gives the error that workspace URL is not valid. I don't think it is a coincidence. Just providing here as an input in case Microsoft decides to investigate the issue. Thanks!