Can someone clear up this weird behavior from my NAT gateway?

Copper Contributor

 Hi all, so I am following Toni Pasanen's AZ Networking Fundamentals book and I hit a roadblock here.


I have set up a VM with no public IP address and put it behind a nat gateway. From this device I have internet access, but I am unable to ping (I tried Furthermore, when I run the command to see what my natted address is in the internet, it does not show the public ip of the nat gateway:






Non-authoritative answer:






These two addresses (the 13 and 76 ones) are not what my nat gateway are supposed to be using.


Any tips would help here.


1 Reply
Regarding the ping failing, I believe this behavior is expected when you don't have a public IP on your VM. Nonetheless, this should not be a problem and you can use any TCP ping tool to test network connectivity like Psping.

For the second point, I am not sure if the commands you use is the correct way to test your public IP. I ran them from my machine and I got the same results and IPs you got. Try to use this instead: