SOLVED

Advanced Analytics Portal

%3CLINGO-SUB%20id%3D%22lingo-sub-99863%22%20slang%3D%22en-US%22%3EAdvanced%20Analytics%20Portal%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-99863%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20not%20able%20to%20login%20to%20the%20Andvanced%20Analytics%20Portal%20-%20stuck%20at%20'Hold%20on%20authentication%20is%20in%20progress'.%20Tried%20with%20a%20several%20different%20Log%20Analytics%20resources%2C%20even%20ones%20in%20different%20subscriptions.%20Any%20ideas%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-99863%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20Log%20Analytics%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-100288%22%20slang%3D%22en-US%22%3ERE%3A%20Advanced%20Analytics%20Portal%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-100288%22%20slang%3D%22en-US%22%3ENeed%20to%20add%20%3CA%20href%3D%22https%3A%2F%2Fportal.loganalytics.io%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fportal.loganalytics.io%3C%2FA%3E%2C%20%3CA%20href%3D%22https%3A%2F%2Flogin.microsoftonline.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Flogin.microsoftonline.com%3C%2FA%3E%20and%20%3CA%20href%3D%22https%3A%2F%2Flogin.windows.net%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Flogin.windows.net%3C%2FA%3E%20to%20trusted%20sites%20in%20Edge.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-99964%22%20slang%3D%22en-US%22%3ERe%3A%20RE%3A%20Advanced%20Analytics%20Portal%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-99964%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Noa%2C%20Afraid%20I%20checked%20that%20already.%20The%20user%20is%20in%20AAD%20and%20has%20owner%20permission%20on%20both%20the%20subscription%20and%20the%20workspace.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-99942%22%20slang%3D%22en-US%22%3ERE%3A%20Advanced%20Analytics%20Portal%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-99942%22%20slang%3D%22en-US%22%3EHi%20Felix%2C%20I%20am%20not%20able%20to%20reproduce%20the%20issue%2C%20do%20you%20still%20experience%20it%3F%20One%20idea%20is%20related%20to%20permissions%20(although%20you%20should%20have%20seen%20403%20error%20in%20that%20case).%20Do%20you%20have%20permissions%20on%20the%20subscription%20level%20(not%20only%20on%20the%20workspace%20it%20self)%3F%20In%20the%20past%2C%20authentication%20to%20the%20workspace%20through%20the%20classic%20portal%20is%20not%20the%20same%20as%20the%20auth%20used%20for%20the%20advanced%20analytics%20portal%2C%20which%20required%20AAD%20account%20to%20have%20permissions%20for%20the%20relevant%20subscription.%3C%2FLINGO-BODY%3E
Occasional Contributor

I'm not able to login to the Andvanced Analytics Portal - stuck at 'Hold on authentication is in progress'. Tried with a several different Log Analytics resources, even ones in different subscriptions. Any ideas?

3 Replies
Hi Felix, I am not able to reproduce the issue, do you still experience it? One idea is related to permissions (although you should have seen 403 error in that case). Do you have permissions on the subscription level (not only on the workspace it self)? In the past, authentication to the workspace through the classic portal is not the same as the auth used for the advanced analytics portal, which required AAD account to have permissions for the relevant subscription.

Hi Noa, Afraid I checked that already. The user is in AAD and has owner permission on both the subscription and the workspace.

Best Response confirmed by Noa Kuperberg (Microsoft)
Solution