AADSTS90093 - An administrator has set a policy

%3CLINGO-SUB%20id%3D%22lingo-sub-69297%22%20slang%3D%22en-US%22%3EAADSTS90093%20-%20An%20administrator%20has%20set%20a%20policy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-69297%22%20slang%3D%22en-US%22%3E%3CP%3EWe're%20in%20the%20process%20of%20trialling%20email%20apps%20from%20the%20Google%20Play%20Store%20and%20seeing%20what%20could%20be%20used%20as%20an%20alternative%20to%20the%20native%20email%20client%20or%20the%20Microsoft%20Outlook%20app.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20trying%20to%20login%20to%20an%20email%20app%20to%20access%20the%20Office%20365%20account%2C%20it%20displays%20an%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22Sorry%2C%20but%20we're%20having%20trouble%20with%20signing%20you%20in.%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Efollowed%20by%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22AADSTS90093%3A%20An%20administrator%20of%20%3CTENANT%3E%20has%20set%20a%20policy%20that%20prevents%20you%20from%20granting%20%3CAPP%3E%20the%20permissions%20it%20is%20requesting.%20Contact%20an%20administrator%20of%20%3CTENANT%3E%20who%20can%20grant%20permissions%20to%20this%20application%20on%20your%20behalf.%22%3C%2FTENANT%3E%3C%2FAPP%3E%3C%2FTENANT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUsing%20the%20Enterprise%20Application%20section%20in%20Azure%20AD%2C%20i've%20assigned%20the%20app%20to%20the%20user%20account%20but%20still%20the%20error%20persists.%20%26nbsp%3BI'm%20not%20exactly%20sure%20what%20i'm%20doing%20wrong%20as%20from%20what%20i%20can%20see%2C%20the%20user%20account%20has%20permission%20to%20use%20the%20app.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-69297%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%20AD%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-69366%22%20slang%3D%22en-US%22%3ERe%3A%20AADSTS90093%20-%20An%20administrator%20has%20set%20a%20policy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-69366%22%20slang%3D%22en-US%22%3EThanks%20Vasil%2C%20I%20did%20come%20across%20that%20same%20doc%20originally%20but%20I%20don't%20have%20the%20option%20it's%20saying%20in%20the%20step%206.%20There%20is%20no%20'required%20permissions'%20section%20nor%20anywhere%20else%20with%20'grant%20permissions'.%3CBR%20%2F%3E%3CBR%20%2F%3EIn%20Azure%20AD%2C%20Enterprise%20Applications%2C%20then%20the%20properties%20of%20the%20app%20has%20no%20option%20as%20listed%20in%20the%20doc.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-69324%22%20slang%3D%22en-US%22%3ERe%3A%20AADSTS90093%20-%20An%20administrator%20has%20set%20a%20policy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-69324%22%20slang%3D%22en-US%22%3E%3CP%3EAn%20administrator%20needs%20to%20grant%20consent%20to%20the%20app%2C%20step%206%20here%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fdevelop%2Factive-directory-integrating-applications%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fdevelop%2Factive-directory-integrating-applications%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

We're in the process of trialling email apps from the Google Play Store and seeing what could be used as an alternative to the native email client or the Microsoft Outlook app.

 

When trying to login to an email app to access the Office 365 account, it displays an error:

 

"Sorry, but we're having trouble with signing you in."

 

followed by

 

"AADSTS90093: An administrator of <Tenant> has set a policy that prevents you from granting <App> the permissions it is requesting. Contact an administrator of <Tenant> who can grant permissions to this application on your behalf."

 

Using the Enterprise Application section in Azure AD, i've assigned the app to the user account but still the error persists.  I'm not exactly sure what i'm doing wrong as from what i can see, the user account has permission to use the app.

 

Any help appreciated.

2 Replies
Thanks Vasil, I did come across that same doc originally but I don't have the option it's saying in the step 6. There is no 'required permissions' section nor anywhere else with 'grant permissions'.

In Azure AD, Enterprise Applications, then the properties of the app has no option as listed in the doc.