Home
Microsoft

Skype Room Systems v2 3.1.104.0 Update

Skype Room Systems v2 3.1.104.0 has been available as an automatic update since April 16th.

 

3.1.104.0 Release Notes are as follows:

  • Fix to improve OSK (on-screen keyboard) behavior in Window 10 Version 1709-based systems
  • Improvements to prepare for future operating system updates
44 Comments
Senior Member

Has the block been lifted on 1709? 

Our SFB is running this version and we have had consistent issues with the virtual keyboard not coming up on Skype (only). 

 

We have tried numerous fixes, was hoping that this update would have fixed it. It has not.

 

This thread here describes our issue pretty accurately:

 

https://techcommunity.microsoft.com/t5/Skype-for-Business-Users/Problem-with-Keyboard-Display-in-Sky...

Occasional Visitor

Hi,

thanks for this Information. Is there a package available for first-time-Installation as well? The prevouisly posted link https://go.microsoft.com/fwlink/?linkid=851168 is not working.

Kind regards,

Oliver

 

Occasional Contributor

Virtual keyboard in 1709 is blocked by Applocker. You need to add a rule to Applocker to allow ShellExperience and InputApp

Frequent Visitor
Download links for the msi and script appear to not be working.
Senior Member

UPDATE : Resolved by fallowing David Tse (SKYPE) comment : 

@James Vajoumounien - Can you try following the instructions here: http://aka.ms/srsupdate and let me know if this resolves the issues you are hitting?

 

Thanks.

 

Hi,

I just update into 3.1.104.0 and getting this error on startup

img.png

 

and on event log, I’ve this:

im2.png

 

Could you please help ?

 

Thanks in advance.

New Contributor

Update: Seems that it just takes time. We had it plugged in for about 48 hours, and then it updates. Nevermind :)

 

Hi! I posted this on a different thread, but before I open a ticket, I wanted to find out how to get the SRS v2 updated. We just received a Logitech Smart Dock, and it's running 3.0.12. 

 

I've gone into the Windows Store, selecting update, but the SRS does not seem to be available. We are not using SCCM, and it is not joined to a domain. 

 

I've looked over various guides and they all point to Windows Store as being the update mechanism, but I'm not having any luck. Any suggestions?

@James Vajoumounien - Can you try following the instructions here: http://aka.ms/srsupdate and let me know if this resolves the issues you are hitting?

 

Occasional Contributor

I have the same question as @Devon Gansebom.

 

Our SRS was upgraded to 3.1.104 this week but still running Win10 1703. When trying to upgrade to 1709 it says that the "Riegel / SRS-app" has to be uninstalled due to incompatibility. 

@Erlend Moen - We are working with Windows to remove the upgrade block for Win10 1703. However, we are still working through some bugs in their update process that may cause problems (it might uninstall the SkypeRoomSystem app).

 

In the meantime, you can force an update to Windows 1709 and ensure your system remains in a good state by following the instructions here: http://aka.ms/srsupdate. The guidance is written to help users upgrade from Win10 1607 (since it is out of support) but it should work for Win10 1703 systems as well.

Senior Member

Hi @David Tse (SKYPE)

I've update 4 systemes without any issue and for some others I'm getting this error:

Disabling AppLocker...
Remove-Item : Cannot remove item C:\WINDOWS\System32\AppLocker\AppCache.dat: The process cannot access the file
'C:\WINDOWS\System32\AppLocker\AppCache.dat' because it is being used by another process.
ERROR: Failed to remove AppLocker file AppCache.dat. Please delete all contents under C:\WINDOWS\System32\AppLocker and try again.

 

I've rebooted and tried twice but doesn't work.

Could you please help me ?

New Contributor

Hi all,

 

I also receive an error which causes the Skype app to hang:

 

The program Microsoft.SkypeRoomSystem.exe version 3.1.104.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 3ac
Start Time: 01d3d8874cb29873
Termination Time: 4294967295
Application Path: C:\Program Files\WindowsApps\Microsoft.SkypeRoomSystem_3.1.104.0_x64__8wekyb3d8bbwe\Microsoft.SkypeRoomSystem.exe
Report Id: 0ba4a429-6b01-4fef-9faa-9e29298f1bc6
Faulting package full name: Microsoft.SkypeRoomSystem_3.1.104.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

I opened a premiere case now. Hopefully we can get rid of this error, since we're rolling out soon.

@James Vajoumounien - Let me investigate this today and get back to you.

@Emanuel Malacarne - I seen this happen recently, however I am unable to repro the issue afterwards. 2 questions: (1) Does the app hang repeatedly for you? (2) Can you follow the instructions below and share resulting logs with me?

 

  • Login as admin  
  • Open Elevated Powershell prompt  
  • cd c:\Rigel\x64\scripts\provisioning
  • powershell -executionpolicy unrestricted .\ScriptLaunch.ps1 CollectSrsV2Logs.ps1  
  • the logs ( zip)  file will get created under C:\rigel\
  • message me a link to the logs and note time of the hang
Frequent Visitor
I must be doing something wrong, I have the removable media (64GB) connected to my machine and formatted correctly in FAT32. When I run the script however it fails returning "You do not have any valid media plugged in. Ensure that you have a FAT32 formatted removable drive inserted into the computer." Any ideas?
New Contributor

Hi Davit,

 

I retrieved the log files from the affected machine.

Our company doesn't have any possibility to upload the files to a location, where I could share it with you.

 

However, I uploaded it to my Microsoft Premier Support case.

Do you have access there?

 

Best regards,

Emanuel

 

@James Vajoumounien - I believe I found the issue you are hitting. Sent you a direct message with a potential fix. Please let me know if that works so I can validate the change.

New Contributor

Since the upgrade to 3.1.104.0, we do not have audio in meetings. I'm new to this system, but I've gone into the admin login, tested the microphone and speakers and they seem to be working correctly. I've also tested the room account in the Skype for Business app on my desktop, audio seems to work fine with it. 

 

I've attempted to invite people from the console, join the Skype room to an active Skype meeting, and send a meeting request, none of which play audio in the system, however audio between the other meeting members works fine.

 

We have a Logitech Smart Dock with a Large Group system. 

 

I don't know if this has to do with the update, still troubleshooting, but wanted to make you aware.

@Lynn Towle - Can you launch the Settings experience by pressing the gear icon in the bottom right of SRS app home screen. Choose Settings. One of the tabs in the settings experience allow you to configure audio devices using the drop down controls on the right.

 

Try configuring the audio devices from that experience and let me know if that works for you.

New Contributor

That was it. It defaulted it to the headphone jack for some reason. Sorry I didn't catch that before, love the system though! It's nice to be able to join and create adhoc meetings! 

Senior Member

so far , i have 7 skype room meeting rooms = ) so far the skye call + presentation is stable now . Its not freezing anymore as we have install sccm and block gpo policy . 

 

My question now is , how to manage or monitor this device remotely? Anyone can share? 

 

 

New Contributor

Hi @rodelmurex,

 

Currently, we're using a PowerShell Script which makes use of these commands:

https://docs.microsoft.com/en-us/skypeforbusiness/manage/skype-room-systems-v2/skype-room-systems-v2...

 

This enables us to pull information on demand of a specific dock or all the docks in a specific organisational unit.

 

In the near future, we're going to implement an active monitoring with OMS:

https://docs.microsoft.com/en-us/skypeforbusiness/manage/skype-room-systems-v2/oms

 

Hope that gives you a nudge in the right direction =)

 

Best regards,

Emanuel

 

Senior Member

Hi,

Since I upgrade into 3.1.104.0, I've a same issue as Emanuel Malacarne : https://techcommunity.microsoft.com/t5/Skype-for-Business-Blog/Skype-Room-Systems-v2-3-1-104-0-Updat...

 

 Could you please help ?

 

Thanks in advance.

Occasional Visitor

Hello,

We have an issue this version on our Surface 4 (Logitech SmartDock). After one day we get an error on the Surface: "Unable to fetch calendar" and no calendar information is updated anymore. Several reboots of the device will not help. If we go into the settings and remove and re-add the password for the configured Active Directory account of the room, it works again till the next day...

 

Michael


Senior Member

@Emanuel Malacarne thanks . let me check this .

 

Senior Member

hi all, do you encounter this , we have deployed 4 smartdock in our china office but it keeps on reconnecting consistently when idle every 3mins. it so strange , is there anything I can change this? this didn't happen to our main office.

 

 

New Contributor

@rodelmurex   yes, I have several SmartDocks that are disconnecting themselves, it will say "Reconnecting..." in the Skype app status. I have to reboot every time to fix it. Any solution?

Regular Visitor
Hi, What about the migration from skype for business to teams (https://docs.microsoft.com/en-us/MicrosoftTeams/journey-skypeforbusiness-teams). What is the plan for SRS? Thanks
Visitor

Hi David, could you please update the download link? our organization plans to deploy new room however this download link for SRSDeploymentKit is no longer valid in powershell script.

 

Thanks

Wayne

@Wayne Xia Apologies. The download link should be fixed now. https://go.microsoft.com/fwlink/?linkid=851168


Senior Member

we do have strange issue. When we do adhoc or unplanned meeting, join by 4 participant plus presentation sharing, the Skype crash itself. it happens already on two device. But when you organize a Skype meeting by simply tapping "join" there was no issue at all.

 

anyone experience this?  can I share the logs

 

I wil try to check my other 5 smardock tomorrow

 

Faulting application name: DesktopAPIService.exe, version: 3.1.104.0, time stamp: 0x5acbcc1c

Faulting module name: KERNELBASE.dll, version: 10.0.15063.1029, time stamp: 0x008ecb0e

Exception code: 0xe0434352

Fault offset: 0x000000000006a1a8

Faulting process id: 0x1980

Faulting application start time: 0x01d3e6b1b42efa79

Faulting application path: C:\Program Files\WindowsApps\Microsoft.SkypeRoomSystem_3.1.104.0_x64__8wekyb3d8bbwe\DesktopAPIService\DesktopAPIService.exe

Faulting module path: C:\Windows\System32\KERNELBASE.dll

Report Id: b33145cb-8eb3-4fcb-b6c1-b6905c60cdb5

Faulting package full name: Microsoft.SkypeRoomSystem_3.1.104.0_x64__8wekyb3d8bbwe

Regular Visitor

UPDATE: Force the Update from 1709 to 1803, the two issue was fixed.

 

 

Hi All,

 

we update a Logitech SmartDock from W10 1703 to W10 1709 following this instruction. now the system is on W10 1709 with SRS , we have two issues:

 

1 - On-screen Keyboard: unable to write the "dot" in both way (alphabetic and number)

2 - unable to open "Advanced Menu", just tap on gear icon, advanced, we can hear the sound of the security credential windows but it don't get the focus.

 

Any Ideas?

 

Many Thanks,

 

Salvatore

New Contributor

If I click the gear-shaped settings icon, it is not very responsive & you have to click it multiple times. (That causes two UAC prompts to pop up.) After the UAC prompt closes, the settings menu does not open, and the whole Skype app freezes, requiring a reboot.

Regular Visitor

 Hi nik, 

Did you update to w10 1803?

New Contributor

I might try it on one device but I don't have a way to manage updates on all devices right now. 1709 is still blocked for automatic updates, let alone 1803.

Microsoft

@Salvatore Bruno - The following regressions have been reported for Windows 10 Version 1709 after an update was pushed in the April timeframe.  We expect a fix from the Windows team in June.

 

  1. Open the touch keyboard in French or Italian. Touch “.”  Button on the keyboard does not respond.
  2. Open the touch keyboard in French. Number pad on the touch keyboard does not input expected character when touch. No repro in Italian language.

The only workaround to propos at the current time would be setting the system language to English.

 

Finally, Dutch may also be affected by the regressions described above.

Regular Visitor

@David GroomWe just jump to 1803 W10, we are testing and at the moment, we do not have any issue. Do you have any update on this version (1803)? Will it be validated in the next weeks? 

 

Thanks

Regular Visitor

@Nick DiFeoI just followed this document to upgrade to 1709, after some issue on that built, I upgrade to 1803 using the same documentation.

Microsoft

@Salvatore Bruno No estimated release date for 1803 at this point (although we are testing).  Please note that 1803 is *not* yet officially supported on Skype Room Systems v2.  Thank you for your understanding.

Regular Visitor

@David Groomsorry about that, but the 1803 is rolling out, so also the MSR will try to install it and you'll find this on the devices:1803_PowershellNeeded.png

 

 

Microsoft

@Salvatore Bruno Is your deployment using WSUS to host Windows updates?  Or do you have a direct connection to the Internet?

Regular Visitor

@David Groomthey are connected directly to the Internet.

Hi,

We experience quite often that the Skype room systems application crashes during a Skype meeting.

Yesterday it crashed 3 times during 1 hour. It automatically restarts and you can join the meeting again.

In the eventlog I can see a event for a application crash.

 

We are running Windows 10 1703 and room systems version 3.1.104.0.

 

Any suggestions on how to solve this issue?

New Contributor

Hi Kim,

 

We experienced the same issue with about 10 deployed test systems.

I could get rid of it by performing the steps described here:

https://docs.microsoft.com/en-us/skypeforbusiness/manage/skype-room-systems-v2/recovery-tool

 

1. Perform this command in Powershell
Remove-Item -Path 'c:\Recovery\OEM\$oem$\$1\Rigel' -Force -Recurse

2. Update the device to Windows 1709

 

3. Run the Powershell.exe command -ExecutionPolicy Unrestricted -File "<path to RecoveryTool.ps1>"
and select 1:"Repair System".

 

After that, all our systems run (more or less) smoothly.

 

Hope that helps,

Emanuel

Hi David,

our test SRS is updated to 4.0.8.0, System and Keyboard are set to English, I can type "." in the virtual keyboard when I'm logged as Administrator, but if I swithc to Skype account the "." stop to work.
Is there any workaround?
Thank you.

Regards

Luca