%3CLINGO-SUB%20id%3D%22lingo-sub-368203%22%20slang%3D%22en-US%22%3ESAP%20Support%20for%20SQL%20Server%202017%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-368203%22%20slang%3D%22en-US%22%3E%0A%20%26lt%3Bmeta%20http-equiv%3D%22Content-Type%22%20content%3D%22text%2Fhtml%3B%20charset%3DUTF-8%22%20%2F%26gt%3B%3CSTRONG%3EFirst%20published%20on%20MSDN%20on%20Jun%2028%2C%202018%20%3C%2FSTRONG%3E%20%3CBR%20%2F%3E%20We%20are%20happy%20to%20share%20that%20SAP%20released%20support%20for%20SQL%20Server%202017%20for%20some%20SAP%20NetWeaver%20based%20systems.%20In%20this%20blog%20we%20will%20talk%20about%20how%20you%20can%20update%20your%20existing%20installations%20on%20SQL%20Server%20to%20SQL%20Server%202017%2C%20what%20you%20need%20to%20do%20when%20installing%20a%20new%20SAP%20NetWeaver%20based%20system%20on%20SQL%20Server%202017%20and%20what%20to%20consider%20when%20upgrading%20an%20SAP%20NetWeaver%20based%20system%20which%20is%20already%20running%20on%20SQL%20Server%202017.%20We%20will%20also%20list%20all%20supported%20products%20and%20the%20required%20Support%20Package%20Stacks.%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20For%20the%20first%20time%2C%20you%20do%20not%20need%20to%20apply%20new%20Support%20Packages%20Stacks%20if%20you%20are%20already%20running%20on%20a%20supported%20SPS%20for%20SQL%20Server%202016.%20The%20minimum%20SPS%20are%20the%20same.%20You%20only%20need%20a%20new%20SAP%20Kernel%20and%20ODBC%20driver.%20%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId-1707533533%22%20id%3D%22toc-hId-1732351393%22%3ESQL%20Server%20RDBMS%20DVD%3C%2FH2%3E%3CBR%20%2F%3E%20%3CSTRONG%3EImportant%20%3C%2FSTRONG%3E%20%3A%20Please%20read%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F2139358%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202139358%20%3C%2FA%3E%20(Login%20required)%20and%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F2534720%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202534720%20%3C%2FA%3E%20(Login%20required)%20on%20more%20information%20about%20how%20and%20where%20to%20download%20the%20SQL%20Server%202017%20RDBMS%20DVD.%20%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId--844623428%22%20id%3D%22toc-hId--819805568%22%3EInstallation%20of%20SAP%20NetWeaver%3C%2FH2%3E%3CBR%20%2F%3E%20The%20following%20SAP%20NetWeaver%20based%20products%20are%20supported%20on%20SQL%20Server%202017%3A%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3ESAP%20products%20based%20on%20SAP%20NetWeaver%20Java%20for%20releases%20SAP%20NetWeaver%207.1%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20products%20based%20on%20SAP%20NetWeaver%20ABAP%20for%20releases%20SAP%20NetWeaver%207.0%20and%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%20PI%20for%20releases%20SAP%20NetWeaver%207.1%20and%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Solution%20Manager%207.2%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%20The%20following%20SAP%20NetWeaver%20based%20products%20are%20%3CSTRONG%3E%20not%20%3C%2FSTRONG%3E%20supported%20on%20SQL%20Server%202017%3A%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Solution%20Manager%207.1%20and%20earlier%20releases%20of%20SAP%20Solution%20Manager%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20CRM%205.0%20and%20SAP%20CRM%206.0%20(also%20known%20as%20SAP%20CRM%202007)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20SCM%205.0%20and%20SAP%20SCM%205.1%20(also%20known%20as%20SAP%20SCM%202007)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20SRM%205.0%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%20Developer%20Workplace%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%20Java%207.0x%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%20Before%20you%20start%20with%20the%20installation%2C%20please%20read%20the%20following%20SAP%20Notes%3A%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3ERelease%20planning%20Note%20%E2%80%93%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F2492596%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202492596%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESetting%20up%20Note%20%E2%80%93%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F2484674%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202484674%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ERequired%20SQL%20Server%20patches%20%E2%80%93%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F62988%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%2062988%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESWPM%20Note%20and%20required%20Kernel%20DVD%20%E2%80%93%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1680045%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201680045%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ECentral%20Note%20for%20SL%20Toolset%20%E2%80%93%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1563579%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201563579%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId-898186907%22%20id%3D%22toc-hId-923004767%22%3ERequirements%3C%2FH2%3E%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EWindows%20Server%202012%2064-bit%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESQL%20Server%202017%20Enterprise%20Edition%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId--1653970054%22%20id%3D%22toc-hId--1629152194%22%3EPreparation%3C%2FH2%3E%3CBR%20%2F%3E%3CH3%20id%3D%22toc-hId--107673224%22%20id%3D%22toc-hId--82855364%22%3ESAP%20Software%20Provisioning%20Manager%3C%2FH3%3E%3CBR%20%2F%3E%20See%20SAP%20Note%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1680045%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201680045%20%3C%2FA%3E%20(Login%20required)%20on%20where%20to%20download%20the%20SWPM.%20Please%20make%20sure%20to%20always%20download%20the%20latest%20SWPM%20and%20the%20SWPM%20that%20matches%20the%20SAP%20NetWeaver%20version%20that%20you%20want%20to%20install%20(e.g.%20for%20SAP%20NetWeaver%207.0%20based%20products%20you%20need%20to%20download%2070SWPM).%20%3CBR%20%2F%3E%20You%20need%20to%20download%20at%20least%20SAP%20Software%20Provisioning%20Manager%201.0%20SP23.%20%3CBR%20%2F%3E%3CH3%20id%3D%22toc-hId-1635137111%22%20id%3D%22toc-hId-1659954971%22%3EKernel%20DVD%3C%2FH3%3E%3CBR%20%2F%3E%20For%20installations%20with%20SWPM%207.0x%20(70SWPM)%2C%20see%20SAP%20Note%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1680045%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201680045%20%3C%2FA%3E%20(Login%20required)%20on%20where%20to%20download%20the%20latest%20Kernel%20DVD.%20%3CBR%20%2F%3E%20Use%20the%20archive%20based%20installation%20for%20installations%20with%20SWPM.%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20For%20SAP%20products%20based%20on%20SAP%20NetWeaver%207.4%20and%20higher%2C%20use%20the%207.49%20DCK%20Kernel%20%3CBR%20%2F%3E%20For%20SAP%20products%20based%20on%20EHP1%20for%20SAP%20NetWeaver%207.3%20and%20lower%20use%20the%20721_EXT%20Kernel%20DVD%20(only%20the%20EXT%20Kernel%20is%20supported)%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20SAP%20recommends%20using%20the%20latest%26nbsp%3BSP%20stack%20kernel%20(SAPEXE.SAR%20and%20SAPEXEDB.SAR)%2C%20available%20in%20the%20Support%20Packages%20%26amp%3B%20Patches%20section%20of%20the%20SAP%20Support%20Portal%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%20https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fsoftwarecenter%20%3C%2FA%3E%20.%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20For%20existing%20installations%20of%20NetWeaver%207.40%2C%207.50%20and%20AS%20ABAP%207.51%20this%20is%20SAP%20Kernel%26nbsp%3B749%20PL%20500.%20For%20details%2C%20see%20release%20note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202626990%20%3C%2FA%3E%20.%20%3CBR%20%2F%3E%20For%20new%20installations%20of%20NetWeaver%207.40%2C%207.50%20and%20AS%20ABAP%207.51%20this%20is%20SAP%20Kernel%26nbsp%3B753%20PL%20100.%20For%20details%2C%20see%26nbsp%3BDCK%20note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202556153%20%3C%2FA%3E%20and%20release%20note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202608318%20%3C%2FA%3E%20.%20%3CBR%20%2F%3E%20For%20AS%20ABAP%207.52%20this%20is%20SAP%20Kernel%20753%20PL%20100.%20For%20details%2C%20see%20release%20note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202608318%20%3C%2FA%3E%20.%20%3CBR%20%2F%3E%3CH3%20id%3D%22toc-hId--917019850%22%20id%3D%22toc-hId--892201990%22%3EJava%20DVD%3C%2FH3%3E%3CBR%20%2F%3E%20See%20SAP%20Note%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1680045%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201680045%20%3C%2FA%3E%20(Login%20required)%20on%20where%20to%20download%20the%20Java%20DVD%20for%20the%20product%20you%20want%20to%20install.%20%3CBR%20%2F%3E%3CH3%20id%3D%22toc-hId-825790485%22%20id%3D%22toc-hId-850608345%22%3EODBC%20driver%3C%2FH3%3E%3CBR%20%2F%3E%20If%20you%20want%20to%20install%20a%20distributed%20SAP%20System%20(database%20and%20SAP%20application%20Server%20are%20running%20on%20different%20hosts)%2C%20make%20sure%20that%20the%20latest%20ODBC%20driver%20for%20Microsoft%20SQL%20Server%20is%20installed%20on%20the%20host%20running%20your%20SAP%20application%20Server.%20See%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1902794%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201902794%20%3C%2FA%3E%20(Login%20required)%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20The%20ODBC%20driver%20can%20also%20be%20downloaded%20from%20the%20Microsoft%20Download%20Center%20%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId--1529852971%22%20id%3D%22toc-hId--1505035111%22%3EInstallation%3C%2FH2%3E%3CBR%20%2F%3E%20Install%20your%20SAP%20system%20using%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EThe%20SAP%20Software%20Provisioning%20Manager%20SAR%20archive%20(SWPM.SAR%20or%2070SWPM.SAR)%201.0%20SP23%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EThe%20SAP%20Software%20Provisioning%20Manager%20Kernel%20DVD%20(for%20installations%20with%2070SWPM.SAR)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EKernel%20archives%20of%20SAP%20Kernel%207.21%20EXT%2C%207.22EXT%2C%207.49%20or%207.53%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EThe%20Java%20DVD%20as%20described%20in%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1680045%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201680045%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EThe%20DVDs%20that%20were%20originally%20shipped%20with%20the%20SAP%20product%20(Export%20DVD%2C%20language%20DVDs%E2%80%A6)%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%20To%20install%20the%20SAP%20NetWeaver%20based%20system%2C%20follow%20these%20steps%3A%20%3CBR%20%2F%3E%3COL%3E%3CBR%20%2F%3E%3CLI%3EAfter%20the%20Installation%20upgrade%20your%20kernel%20to%20the%20latest%207.21%20EXT%2F7.22%20EXT%20Kernel%20or%207.49%20Kernel.%207.22%20EXT%20Kernel%20is%20recommended%20for%20SAP%20System%20based%20on%20SAP%20NetWeaver%207.31%20or%20lower.%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EABAP%2FABAP%2BJAVA%3A%20Connect%20your%20new%20SAP%20System%20to%20your%20SAP%20Solution%20Manager%20(only%20required%20if%20you%20do%20not%20install%20SAP%20Solution%20Manager)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EABAP%2FABAP%2BJAVA%3A%20Create%20a%20maintenance%20stack%20to%20implement%20at%20least%20(only%20required%20if%20you%20do%20not%20install%20SAP%20Solution%20Manager)%3A%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Business%20Suite%202005%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3ESAP%20ERP%206.0%20SPS%2028%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Business%20Suite%207%20Support%20Release%201%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3ESAP%20CRM%207.0%20SPS%2018%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP4%20for%20SAP%20ERP%206.0%20SPS%2018%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20SCM%207.0%20SPS%2018%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20SRM%207.0%20SPS%2019%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Business%20Suite%207i%202010%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EEHP1%20for%20SAP%20CRM%207.0%20SPS%2015%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP5%20for%20SAP%20ERP%206.0%20SPS%2015%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP1%20for%20SAP%20SCM%207.0%20SPS%2015%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP1%20for%20SAP%20SRM%207.0%20SPS%2015%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Business%20Suite%207i%202011%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EEHP2%20for%20SAP%20CRM%207.0%20SPS%2016%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP6%20for%20SAP%20ERP%206.0%20SPS%2016%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP2%20for%20SAP%20SCM%207.0%20SPS%2016%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP2%20for%20SAP%20SRM%207.0%20SPS%2016%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Business%20Suite%207i%202013%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EEHP3%20for%20SAP%20CRM%207.0%20SPS%2010%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP7%20for%20SAP%20ERP%206.0%20SPS%2010%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP3%20for%20SAP%20SCM%207.0%20SPS%2010%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP3%20for%20SAP%20SRM%207.0%20SPS%2010%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Business%20Suite%207i%202016%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EEHP4%20for%20SAP%20CRM%207.0%20SPS%2001%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP8%20for%20SAP%20ERP%206.0%20SPS%2001%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP4%20for%20SAP%20SCM%207.0%20SPS%2001%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EEHP4%20for%20SAP%20SRM%207.0%20SPS%2001%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.1%20SPS%2020%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.1%20including%20EHP1%20SPS%2015%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.3%20SPS%2014%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.3%20including%20EHP1%20SPS%2017%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.4%20SPS%2012%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.5%20SPS%2001%20or%20higher%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20NetWeaver%207.51%20and%20higher%20do%20not%20need%20additional%20support%20packages%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EABAP%2FABAP%2BJAVA%3A%20Use%20the%20Software%20Update%20Manager%20(SUM)%201.0%20SP17%20or%20higher%20to%20implement%20the%20maintenance%20stack%20(only%20required%20if%20you%20do%20not%20install%20SAP%20Solution%20Manager)%20%3CBR%20%2F%3E%20%3CSTRONG%3E%20DO%20NOT%20%3C%2FSTRONG%3E%20use%20SPAM%20to%20implement%20the%20support%20packages%20%3CBR%20%2F%3E%20%3CSTRONG%3E%20DO%20NOT%20%3C%2FSTRONG%3E%20update%20SPAM%20manually%20but%20let%20the%20SUM%20update%20the%20SPAM%20as%20part%20of%20the%20maintenance%20stack%20implementation%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ESAP%20Solution%20Manager%207.2%20only%3A%20Use%20the%20Software%20Update%20Manager%20(SUM)%201.0%20SP17%20to%20install%20SAP%20Solution%20Manager%207.2%20SR1%20which%20already%20contains%20the%20required%20SPS%2001%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FOL%3E%3CBR%20%2F%3E%3CH3%20id%3D%22toc-hId-16443859%22%20id%3D%22toc-hId-41261719%22%3EPost%20Steps%3C%2FH3%3E%3CBR%20%2F%3E%20Configure%20your%20SQL%20Server%20as%20described%20in%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F2484657%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%202484657%20%3C%2FA%3E%20(Login%20required)%20%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId--1453923032%22%20id%3D%22toc-hId--1429105172%22%3ESystem%20Copy%20of%20SAP%20NetWeaver%3C%2FH2%3E%3CBR%20%2F%3E%20You%20can%20also%20copy%20your%20SAP%20System%20that%20is%20running%20on%20an%20older%20SQL%20Server%20release%20to%20a%20machine%20running%20a%20new%20SQL%20Server%20with%20the%20following%20steps%3A%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EMake%20sure%20that%20your%20source%20system%20is%20at%20least%20on%20the%20support%20package%20stack%20as%20described%20in%20the%20installation%20section%20if%20this%20blog.%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3ECopy%20your%20SAP%20system%20using%20%3CBR%20%2F%3E%3CUL%3E%3CBR%20%2F%3E%3CLI%3EThe%20SAP%20Software%20Provisioning%20Manager%201.0%20SP23%20or%20higher%20SAR%20archive%20(SWPM.SAR%20or%2070SWPM.SAR)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EThe%20SAP%20Software%20Provisioning%20Manager%20Kernel%20DVD%20for%20installations%20with%2070SWPM%20or%20the%20lastest%20archives%20of%20the%207.21%20EXT%2C%207.22%20EXT%2C%207.49%20or%207.53%20kernel%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EThe%20Java%20DVD%20as%20described%20in%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1680045%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201680045%20%3C%2FA%3E%20(Login%20required)%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EThe%20DVDs%20that%20were%20originally%20shipped%20with%20the%20SAP%20product%20(Export%20DVD%2C%20language%20DVDs%E2%80%A6)%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%3C%2FLI%3E%3CBR%20%2F%3E%3CLI%3EAfter%20the%20Installation%20upgrade%20your%20kernel%20to%20the%20latest%207.21%20EXT%2C%207.22%20EXT%20Kernel%2C%207.49%20or%207.53%20Kernel.%207.22%20EXT%20Kernel%20is%20recommended%20for%20SAP%20System%20based%20on%20SAP%20NetWeaver%207.31%20or%20lower.%3C%2FLI%3E%3CBR%20%2F%3E%3C%2FUL%3E%3CBR%20%2F%3E%20The%20steps%20for%20a%20System%20Copy%20where%20the%20source%20SAP%20system%20is%20already%20running%20on%20SQL%202017%20are%20the%20same.%20%3CBR%20%2F%3E%3CH2%20id%3D%22toc-hId-288887303%22%20id%3D%22toc-hId-313705163%22%3EUpdate%20or%20Upgrade%20of%20SAP%20NetWeaver%3C%2FH2%3E%3CBR%20%2F%3E%20Only%20updates%20or%20upgrades%20that%20are%20supported%20by%20the%20SAP%20Software%20Update%20Manager%20are%20supported%20for%20SQL%20Server%202017.%20Please%20read%20SAP%20Note%20SAP%20Note%20%3CA%20href%3D%22https%3A%2F%2Flaunchpad.support.sap.com%2F%23%2Fnotes%2F1563579%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%201563579%20%3C%2FA%3E%20(Login%20required)%20to%20find%20the%20SAP%20Note%20for%20the%20latest%20SAP%20Software%20Update%20Manager%20that%20describes%20the%20supported%20update%20and%20upgrade%20scenarios.%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20As%20an%20example%2C%20the%20following%20upgrades%20are%20not%20supported%20by%20SAP%20Software%20Manager%20and%20are%20therefore%20not%20supported%20for%20SQL%20Server%202017%3A%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20Upgrade%20of%20SAP%20CRM%205.0%20to%20SAP%20CRM%207.0%20or%20EHP1%20for%20SAP%20CRM%207.0%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20Upgrade%20of%20SAP%20SCM%205.0%20to%20SAP%20SCM%207.0%20or%20EHP1%20for%20SAP%20SCM%207.0%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20Upgrade%20of%20SAP%20SRM%205.0%20to%20SAP%20SRM%207.0%20or%20EHP1%20for%20SAP%20SRM%207.0%20%3CBR%20%2F%3E%20%3CBR%20%2F%3E%20Use%20at%20least%20SAP%20Software%20Update%20Manager%201.0%20SP22%20or%20SAP%20Software%20Manager%202.0%20SP02%3C%2FLINGO-BODY%3E%3CLINGO-TEASER%20id%3D%22lingo-teaser-368203%22%20slang%3D%22en-US%22%3EFirst%20published%20on%20MSDN%20on%20Jun%2028%2C%202018%20We%20are%20happy%20to%20share%20that%20SAP%20released%20support%20for%20SQL%20Server%202017%20for%20some%20SAP%20NetWeaver%20based%20systems.%3C%2FLINGO-TEASER%3E
Microsoft
First published on MSDN on Jun 28, 2018
We are happy to share that SAP released support for SQL Server 2017 for some SAP NetWeaver based systems. In this blog we will talk about how you can update your existing installations on SQL Server to SQL Server 2017, what you need to do when installing a new SAP NetWeaver based system on SQL Server 2017 and what to consider when upgrading an SAP NetWeaver based system which is already running on SQL Server 2017. We will also list all supported products and the required Support Package Stacks.

For the first time, you do not need to apply new Support Packages Stacks if you are already running on a supported SPS for SQL Server 2016. The minimum SPS are the same. You only need a new SAP Kernel and ODBC driver.

SQL Server RDBMS DVD


Important : Please read SAP Note 2139358 (Login required) and SAP Note 2534720 (Login required) on more information about how and where to download the SQL Server 2017 RDBMS DVD.

Installation of SAP NetWeaver


The following SAP NetWeaver based products are supported on SQL Server 2017:

  • SAP products based on SAP NetWeaver Java for releases SAP NetWeaver 7.1 or higher

  • SAP products based on SAP NetWeaver ABAP for releases SAP NetWeaver 7.0 and higher

  • SAP NetWeaver PI for releases SAP NetWeaver 7.1 and higher

  • SAP Solution Manager 7.2


The following SAP NetWeaver based products are not supported on SQL Server 2017:

  • SAP Solution Manager 7.1 and earlier releases of SAP Solution Manager

  • SAP CRM 5.0 and SAP CRM 6.0 (also known as SAP CRM 2007)

  • SAP SCM 5.0 and SAP SCM 5.1 (also known as SAP SCM 2007)

  • SAP SRM 5.0

  • SAP NetWeaver Developer Workplace

  • SAP NetWeaver Java 7.0x


Before you start with the installation, please read the following SAP Notes:

  • Release planning Note – SAP Note 2492596 (Login required)

  • Setting up Note – SAP Note 2484674 (Login required)

  • Required SQL Server patches – SAP Note 62988 (Login required)

  • SWPM Note and required Kernel DVD – SAP Note 1680045 (Login required)

  • Central Note for SL Toolset – SAP Note 1563579 (Login required)


Requirements



  • Windows Server 2012 64-bit or higher

  • SQL Server 2017 Enterprise Edition


Preparation


SAP Software Provisioning Manager


See SAP Note SAP Note 1680045 (Login required) on where to download the SWPM. Please make sure to always download the latest SWPM and the SWPM that matches the SAP NetWeaver version that you want to install (e.g. for SAP NetWeaver 7.0 based products you need to download 70SWPM).
You need to download at least SAP Software Provisioning Manager 1.0 SP23.

Kernel DVD


For installations with SWPM 7.0x (70SWPM), see SAP Note SAP Note 1680045 (Login required) on where to download the latest Kernel DVD.
Use the archive based installation for installations with SWPM.

For SAP products based on SAP NetWeaver 7.4 and higher, use the 7.49 DCK Kernel
For SAP products based on EHP1 for SAP NetWeaver 7.3 and lower use the 721_EXT Kernel DVD (only the EXT Kernel is supported)

SAP recommends using the latest SP stack kernel (SAPEXE.SAR and SAPEXEDB.SAR), available in the Support Packages & Patches section of the SAP Support Portal https://launchpad.support.sap.com/#/softwarecenter .

For existing installations of NetWeaver 7.40, 7.50 and AS ABAP 7.51 this is SAP Kernel 749 PL 500. For details, see release note 2626990 .
For new installations of NetWeaver 7.40, 7.50 and AS ABAP 7.51 this is SAP Kernel 753 PL 100. For details, see DCK note 2556153 and release note 2608318 .
For AS ABAP 7.52 this is SAP Kernel 753 PL 100. For details, see release note 2608318 .

Java DVD


See SAP Note SAP Note 1680045 (Login required) on where to download the Java DVD for the product you want to install.

ODBC driver


If you want to install a distributed SAP System (database and SAP application Server are running on different hosts), make sure that the latest ODBC driver for Microsoft SQL Server is installed on the host running your SAP application Server. See SAP Note 1902794 (Login required)

The ODBC driver can also be downloaded from the Microsoft Download Center

Installation


Install your SAP system using

  • The SAP Software Provisioning Manager SAR archive (SWPM.SAR or 70SWPM.SAR) 1.0 SP23 or higher

  • The SAP Software Provisioning Manager Kernel DVD (for installations with 70SWPM.SAR)

  • Kernel archives of SAP Kernel 7.21 EXT, 7.22EXT, 7.49 or 7.53

  • The Java DVD as described in SAP Note 1680045 (Login required)

  • The DVDs that were originally shipped with the SAP product (Export DVD, language DVDs…)


To install the SAP NetWeaver based system, follow these steps:

  1. After the Installation upgrade your kernel to the latest 7.21 EXT/7.22 EXT Kernel or 7.49 Kernel. 7.22 EXT Kernel is recommended for SAP System based on SAP NetWeaver 7.31 or lower.

  2. ABAP/ABAP+JAVA: Connect your new SAP System to your SAP Solution Manager (only required if you do not install SAP Solution Manager)

  3. ABAP/ABAP+JAVA: Create a maintenance stack to implement at least (only required if you do not install SAP Solution Manager):

    • SAP Business Suite 2005

      • SAP ERP 6.0 SPS 28 or higher



    • SAP Business Suite 7 Support Release 1

      • SAP CRM 7.0 SPS 18 or higher

      • EHP4 for SAP ERP 6.0 SPS 18 or higher

      • SAP SCM 7.0 SPS 18 or higher

      • SAP SRM 7.0 SPS 19 or higher



    • SAP Business Suite 7i 2010

      • EHP1 for SAP CRM 7.0 SPS 15 or higher

      • EHP5 for SAP ERP 6.0 SPS 15 or higher

      • EHP1 for SAP SCM 7.0 SPS 15 or higher

      • EHP1 for SAP SRM 7.0 SPS 15 or higher



    • SAP Business Suite 7i 2011

      • EHP2 for SAP CRM 7.0 SPS 16 or higher

      • EHP6 for SAP ERP 6.0 SPS 16 or higher

      • EHP2 for SAP SCM 7.0 SPS 16 or higher

      • EHP2 for SAP SRM 7.0 SPS 16 or higher



    • SAP Business Suite 7i 2013

      • EHP3 for SAP CRM 7.0 SPS 10 or higher

      • EHP7 for SAP ERP 6.0 SPS 10 or higher

      • EHP3 for SAP SCM 7.0 SPS 10 or higher

      • EHP3 for SAP SRM 7.0 SPS 10 or higher



    • SAP Business Suite 7i 2016

      • EHP4 for SAP CRM 7.0 SPS 01 or higher

      • EHP8 for SAP ERP 6.0 SPS 01 or higher

      • EHP4 for SAP SCM 7.0 SPS 01 or higher

      • EHP4 for SAP SRM 7.0 SPS 01 or higher



    • SAP NetWeaver 7.1 SPS 20 or higher

    • SAP NetWeaver 7.1 including EHP1 SPS 15 or higher

    • SAP NetWeaver 7.3 SPS 14 or higher

    • SAP NetWeaver 7.3 including EHP1 SPS 17 or higher

    • SAP NetWeaver 7.4 SPS 12 or higher

    • SAP NetWeaver 7.5 SPS 01 or higher

    • SAP NetWeaver 7.51 and higher do not need additional support packages



  4. ABAP/ABAP+JAVA: Use the Software Update Manager (SUM) 1.0 SP17 or higher to implement the maintenance stack (only required if you do not install SAP Solution Manager)
    DO NOT use SPAM to implement the support packages
    DO NOT update SPAM manually but let the SUM update the SPAM as part of the maintenance stack implementation

  5. SAP Solution Manager 7.2 only: Use the Software Update Manager (SUM) 1.0 SP17 to install SAP Solution Manager 7.2 SR1 which already contains the required SPS 01


Post Steps


Configure your SQL Server as described in SAP Note 2484657 (Login required)

System Copy of SAP NetWeaver


You can also copy your SAP System that is running on an older SQL Server release to a machine running a new SQL Server with the following steps:

  • Make sure that your source system is at least on the support package stack as described in the installation section if this blog.

  • Copy your SAP system using

    • The SAP Software Provisioning Manager 1.0 SP23 or higher SAR archive (SWPM.SAR or 70SWPM.SAR)

    • The SAP Software Provisioning Manager Kernel DVD for installations with 70SWPM or the lastest archives of the 7.21 EXT, 7.22 EXT, 7.49 or 7.53 kernel

    • The Java DVD as described in SAP Note 1680045 (Login required)

    • The DVDs that were originally shipped with the SAP product (Export DVD, language DVDs…)



  • After the Installation upgrade your kernel to the latest 7.21 EXT, 7.22 EXT Kernel, 7.49 or 7.53 Kernel. 7.22 EXT Kernel is recommended for SAP System based on SAP NetWeaver 7.31 or lower.


The steps for a System Copy where the source SAP system is already running on SQL 2017 are the same.

Update or Upgrade of SAP NetWeaver


Only updates or upgrades that are supported by the SAP Software Update Manager are supported for SQL Server 2017. Please read SAP Note SAP Note 1563579 (Login required) to find the SAP Note for the latest SAP Software Update Manager that describes the supported update and upgrade scenarios.

As an example, the following upgrades are not supported by SAP Software Manager and are therefore not supported for SQL Server 2017:

Upgrade of SAP CRM 5.0 to SAP CRM 7.0 or EHP1 for SAP CRM 7.0

Upgrade of SAP SCM 5.0 to SAP SCM 7.0 or EHP1 for SAP SCM 7.0

Upgrade of SAP SRM 5.0 to SAP SRM 7.0 or EHP1 for SAP SRM 7.0

Use at least SAP Software Update Manager 1.0 SP22 or SAP Software Manager 2.0 SP02