Forum Discussion
RedPanther10
Oct 06, 2023Copper Contributor
How can I pull up OS versions a Teams Device is Installed?
I search for this question but couldn't find an answer. I'm not sure if anyone answered it before but i want to know how i can see what OS employees are using on TEAMS.
- Oct 08, 2023
Hi RedPanther10
You could use a KQL Query in Azure LogAnalytics:
SigninLogs
| where TimeGenerated > ago(30d)
| where AppDisplayName == "Microsoft Teams"
| where ResultType == 0 //Sucessful Login
| summarize count() by UserPrincipalName, tostring(DeviceDetail.operatingSystem), UserAgentIf you want to use it in PowerShell - maybe this Blog Article will give you some jump start
https://blog.icewolf.ch/archive/2023/01/26/analyze-azuread-signin-logs-with-powershell/
Regards
Andres Bohren
randriksen_
Oct 09, 2023Brass Contributor
or are you actually looking for teams devices? like desktop phones or meeting room equipment? as in something like this: https://www.microsoft.com/en-us/microsoft-teams/across-devices/devices/product/poly-ccx-600-business-media-phone-teams-edition/710
RedPanther10
Oct 10, 2023Copper Contributor
I want to see who has TEAMS downloaded on their phones and laptops. So basically i want to know If person1 has it on their phones, because I'm trying to narrow down calls quality. Andres Bohren response should do the trick.