Forum Discussion
Vshah335
Oct 26, 2020Copper Contributor
Separation of Security incident
I am using this query for security incident but getting all incident that having in Sentinel in that query. How to separate and not having duplication on the incident while generate pie charts. ...
GaryBushey
Oct 27, 2020Bronze Contributor
Vshah335 Try something like:
| summarize arg_max(TimeGenerated) by IncidentNumber
you can add Status inside the arg_max as well.
If you look at the Security Operations Efficiency workbook there are lots of examples of how to get the Incidents by different fields.
Vshah335
Oct 27, 2020Copper Contributor
Thanks GaryBushey for quick reply.
My question is : Ex- we have two X and Y different tenants in same workspace.
ex - if i assigned to my self - New - viral
- Assigned to- viral
- close - viral
So i just want to monitored Y tenant security incident only on top of that when i try run query against it shows results same incident again and again. It's counts 3 incident on results instead of one incident. (Number went high while i generate pie chart )
Is there any why to count main incident which genreated first shows in results ?
Thanks for your response.
- GaryBusheyOct 27, 2020Bronze Contributor
Vshah335 This should do it
SecurityIncident| where TenantID == X| summarize dcount(IncidentNumber) by bin(TimeGenerated, 1d)Where X is the TenantID you care about. Add other fields as needed for charting.