Forum Discussion

GI472's avatar
GI472
Brass Contributor
Jul 02, 2023
Solved

USB events

Hi all,   Random question...   As part of a security training exercise, I want to use a third-party tool to create USB drives with trackable files to test whether users take them to IT to be scan...
  • Hello, unfortunately I searched for some things and found only a few things about usb mounting that you can see in the defender reports.

    I did a kql, but here at the company the usb is blocked and it doesn't work

    kql takes the AdditionalField column and filters on everything that is removable.

    DeviceEvents
    |extend details = todynamic(AdditionalFields)
    |mv-expand usb= details.IsOnRemovableMedia
    | where tostring(usb) contains "true"



    if you liked it mark the answer with a like.
    if you thought this answer helped in any way please mark it as best answer

    Follow me: https://www.linkedin.com/in/raphael-custodio-soares/