Forum Discussion
agim_
Feb 20, 2019Copper Contributor
Redundancy in Query
Hello everyone, I'm am looking for a few pointers on making a more efficient query. Is there a better way of expressing the pseudo-query below? OfficeActivity | where UserId !contains "perso...
Feb 20, 2019
Hi,
If you use !has it will be more performant than !contains. In case UserId values like person@email are the full values and not partial ones you can do this:
OfficeActivity
| where UserId !in~ ("person@email","another@email","user@email")
!in~ should also be more efficient than !contains. Let me know if this answers your question.