Forum Discussion
KQL Syntax question
- Jan 31, 2020
Like this?
union isfuzzy=true (Dependencies | extend DurationA = Duration), (Requests | extend DurationB = Duration) | summarize by DurationA, DurationBExample using demo Tables
Go to Log Analytics and run query
union isfuzzy=true (Event | extend DurationA = EventID | project DurationA ), (SecurityEvent | extend DurationB = EventID | project DurationB) | summarize count(DurationA), count(DurationB)count_DurationA count_DurationB 601533 601533
Vincent20, I am not sure I understood your question nor the goal of your query. But if you want to rename a column, you have to use extend+project-away or simply project-rename.
For example
- Vincent20Jan 30, 2020Copper Contributor
Thank you for this. So the scenario is as follows: I have two tables Dependencies and Requests. Each of these have a column called Duration. So the query I have above merges columns in table 1(Dependencies) and table 2(requests) and combines all common columns in both as one. The problem is that I want to show all columns whether it is common or not, then rename the common column called duration so that I can Identify duration from dependencies and duration from requests. I look forward to your kind responsehspinto
- CliveWatsonJan 31, 2020Former Employee
Like this?
union isfuzzy=true (Dependencies | extend DurationA = Duration), (Requests | extend DurationB = Duration) | summarize by DurationA, DurationBExample using demo Tables
Go to Log Analytics and run query
union isfuzzy=true (Event | extend DurationA = EventID | project DurationA ), (SecurityEvent | extend DurationB = EventID | project DurationB) | summarize count(DurationA), count(DurationB)count_DurationA count_DurationB 601533 601533 - Vincent20Jan 31, 2020Copper ContributorThis is great. Exactly what I want to achieve.