Forum Widgets
Latest Discussions
Looking for guidance on designing an Azure data analytics pipeline for reporting
I’m working on modernizing an old reporting workflow that currently runs on a few on-premises databases and scheduled scripts. The current process collects operational data from multiple systems, performs some basic transformation and aggregation, and then generates reports for different business teams. As the data volume is growing, the existing setup is becoming difficult to maintain and slow to refresh. I’m looking for an Azure-based architecture that can ingest data from different sources, store both raw and processed data, run scheduled transformations, and make the final datasets available for reporting tools like Power BI. Would appreciate any suggestions on the recommended architecture, especially around data storage, transformation, refresh performance, and cost control. ThanksSelinaKnowJul 02, 2026Copper Contributor13Views0likes1Commentretreiving security form d365 CE ?
Hi ! I wondered if someone found a way to retrieve the Row security level of D365 (both CE and F&O) in the data lake export. I don't see how to manage that. security in D365 CE (aka dataverse) is prety complex. Any record belong to one user, one Business unit and one Team. moreover it can be shared with other users. how can I be sure to get this security in my powerbi reports based on the export to data lake ? Finops seems a little bit easier as thez security is based on the legal entity the user belong to. Any welp would be greatly appreciated.FsimJul 01, 2026Tin Contributor695Views0likes1Commentstatus code threshold
Trying to figure out how to find events where status code 200 goes above a certain avg threshold, say 10%. I think I have the avg figured out, but unsure how to get the rest written. Any help would be appreciated. W3CIISLog | where TimeGenerated > ago(7d) |where scStatus =="200" | summarize totalCount = count() by bin(TimeGenerated, 1h), scStatus |summarize avghits =(avg(totalCount))PDisme110Jun 29, 2026Copper Contributor530Views0likes1CommentQuery EPS for specific log collector
Hi, i would like to ask for help for a specific kusto query to get the average eps for a specific log collector? i tried to search the community and tried one of the query i saw but to no avail. hope you can help me as i am still learning sentinel and kusto query. thank you in advance.jdf13ldsJun 10, 2026Copper Contributor667Views0likes1CommentLooking for an Azure solution for time series validation solution
Hi folks, I am planning to replace one of my old on prem based time series based process validation tool with Azure based solution. Required solution should be able to perform validation of time series coming from various different sources like DBs or CSV file etc(eventually data is coming from different plants in those DBs or CSV files) and it should be able to perform certain calculations(based on some defined mathematical functions) on those time series. Post that it should be able to send it to some centralized Datawarehouse where reporing etc can be performed on that gathered data with tools like Power BI or Graphana. I found one similar sort of product which Azure timeseries but it is going to be out of support in 2025.Prashant_2405May 15, 2026Copper Contributor393Views0likes2CommentsIntegrate Jenkins with Azure Databricks & GitHub into VSCode
Hello Team, Greetings of the Day!!! Hope you have a great day ahead!!! We have installed extension of Azure Databricks, GitHub & Jenkins in VSCode. Now the configuration parts come into the picture, so we have configured Azure Databricks & Logged in GitHub in VSCode. Now Turn comes of Jenkins. We want to know that how can we configure Jenkins with GitHub. All Notebooks from Azure Databricks will be version controlled in GitHub for doing that we want to use Jenkins. There is no documentation to do so. Can you guide us how to do it. Reference Link :- https://learn.microsoft.com/en-us/azure/databricks/dev-tools/ci-cd/ci-cd-jenkins Thank You in advance for any Support or Suggestion : ) Looking forward for your valuable input. Regards, Niral Dave.N-SPECMay 04, 2026Copper Contributor515Views0likes1CommentSend custom data to Log Analytics in Azure Functions
When I send custom biz data to Azure Log Analytics in an Azure Function(C# code), I want to use a OperationalInsightsDataColloector, but I can't find the class in Microsoft.Azure.Operationallnsight package from nuget. Anyone knows whehter it is obseleted?eugene1710May 03, 2026Copper Contributor516Views0likes1CommentHi everyone!
Hi everyone! 👋 I’m new to this community and currently learning Azure Analytics. I’m really excited to be here and connect with people who have experience in this field. I believe the discussions and knowledge shared by members here are very valuable, and I’m looking forward to learning from all of you. If you have any advice, resources, or tips for someone starting with Azure Analytics, I’d really appreciate it. Happy to be part of this community! 😊Thinuka99Mar 13, 2026Tin Contributor67Views2likes0CommentsLog Analytics query the logs that are not in IP range
Hi All, I'm struggling with writing a query that will find sign-ins in logs that are not in IP ranges. So we have Log Analytics Workplace which is collecting sign-in logs. And we want to trigger an alert when an account is signed in from an IP that is not in one of our IP ranges. We have a lot of known network rages and we have to use an external repository like github with a txt file of those rages. I've tried to use the function "ipv4_is_match()", but from my understanding, it's looking just like to like, but not looking foreach. That being said I've tried something like this, but it doesn't work. Does anyone experienced here can help with writing such a query, or even answer if it's possible? let ipList = externaldata (IPAddress:string) [ @"https://raw.githubusercontent.com/NameOfRepository/IPv4Range.txt" ]; SigninLogs | where UserPrincipalName contains "email address removed for privacy reasons" | where IsInteractive == true | where not (ipv4_is_match(IPAddress , ipList)Denys_bezshkuryiMar 06, 2026Copper Contributor731Views0likes1CommentAPI Query Results Different from Azure Portal
Hello Team, i 'm running a query that i have connect an API with excel. The results for example for a specific user for a specific a day for a conditional access that blocks legacy authentication are more than the results i m getting from azure portal. What results i 'll trust?ankilo2011Feb 23, 2026Copper Contributor480Views0likes1Comment
Tags
- AMA18 Topics
- azure7 Topics
- Log Analytics6 Topics
- Synapse3 Topics
- azure monitor3 Topics
- Log Analytics Workspace3 Topics
- Stream Analytics2 Topics
- azure databricks2 Topics
- Azure Synapse Analtyics2 Topics
- application insights2 Topics