Blog Post

Exchange Team Blog
2 MIN READ

Action Required: Upgrade ExchangeOnlineManagement PowerShell Module to Version 3.10.1 or Newer

The_Exchange_Team's avatar
The_Exchange_Team
Platinum Contributor
Oct 01, 2026

We have introduced security enhancements to Exchange Online PowerShell authentication in ExchangeOnlineManagement module version 3.10.1 and newer. These enhancements strengthen the authentication flow and provide additional protection against emerging threats.

  1. Customers using a version earlier than 3.10.1 should upgrade to version 3.10.1 or later. Exchange Online authentication will increasingly rely on the security enhancements available in these versions, and older module versions may not support future authentication requirements.
  2. Customers already using version 3.10.1 or later do not need to take any additional action beyond keeping the module up to date.

Microsoft recommends upgrading as soon as possible to benefit from the latest security, reliability, and performance improvements and to prevent any future PowerShell connectivity issues.

What is Changing

Microsoft plans to begin enforcement of more strict logon requirements for Exchange Online PowerShell module on 31st March 2027.

After the enforcement:

  1. ExchangeOnlineManagement versions older than 3.10.1 may experience authentication failures in certain interactive authentication scenarios.
  2. ExchangeOnlineManagement version 3.10.1 and later will continue to function normally.

Upgrading the ExchangeOnlineManagement module to versions 3.10.1 (or newer) is the only thing you need to do. No other changes are required.

Who May Be Affected

You may be affected if you are:

  1. Running ExchangeOnlineManagement versions earlier than 3.10.1.
  2. Using PowerShell 7.
  3. Using interactive authentication with Web Account Manager (WAM) disabled.

You may not be affected if you are using:

  1. ExchangeOnlineManagement version 3.10.1 or later.
  2. Certificate-Based Authentication (CBA).
  3. WAM-based authentication.
  4. Windows PowerShell 5.x.

Regardless of your current scenario, Microsoft recommends upgrading to ExchangeOnlineManagement version 3.10.1 or later to stay aligned with current and future Exchange Online requirements.

To verify the currently installed version:

Get-Module ExchangeOnlineManagement -ListAvailable

The latest version of the ExchangeOnlineManagement module is available from the PowerShell Gallery: ExchangeOnlineManagement PowerShell Module

Frequently Asked Questions

We are already using ExchangeOnlineManagement version 3.10.1 or later. Do we need to do anything?
No additional action is required for this change if you are already running ExchangeOnlineManagement version 3.10.1 or later. Continue keeping the module up to date to receive the latest security, reliability, and performance improvements.

Will our existing scripts be affected if I use Certificate-Based Authentication (CBA)?
No. Scripts and automation that use CBA are not expected to be affected by this enforcement because they do not use interactive authentication. However, Microsoft recommends upgrading to ExchangeOnlineManagement version 3.10.1 or later to stay current with the latest security and reliability improvements.

Does this change require us to enable WAM?
No. This change does not require customers to enable WAM.

Do we need to upgrade to the newer module if our current authentication scenario is not affected?
Yes. Microsoft recommends that all customers upgrade to ExchangeOnlineManagement version 3.10.1 or later, regardless of their current authentication scenario. While some scenarios may not be affected by the initial enforcement, upgrading helps ensure compatibility with current and future Exchange Online authentication requirements.

Exchange Online Manageability Team

Published Oct 01, 2026
Version 1.0

2 Comments

  • MikeCrowley's avatar
    MikeCrowley
    Iron Contributor

    Thanks for the heads-up. One thing worth knowing before people upgrade: 3.10.1 is also the version that conflicts with the Microsoft Graph PowerShell SDK in the same PowerShell 7 session. Graph first, Connect-ExchangeOnline fails with a NullReferenceException in RuntimeBroker; EXO first, Connect-MgGraph fails with a WithLogging MissingMethodException (tested with Graph 2.40.0 and EXO 3.10.1).

     

    It isn't the MSAL version gap, though that's a reasonable first guess: with both modules on MSAL 4.83.1 it still fails. The Graph-first failure is EXO's broker ending up on the msalruntime.dll that Graph already started. Details, a test harness and results are in https://github.com/microsoftgraph/msgraph-sdk-powershell/issues/3394.

     

    Graph 2.41.0 just shipped an isolated load context for its dependencies. Is something similar planned for ExchangeOnlineManagement? Until then the working combination is Graph first, then Connect-ExchangeOnline -DisableWAM.

    22Oct2026 EDIT : Exchange Online 3.11.1-Preview1 landed on the Gallery today and, although the release notes don’t mention it, ships the same sign-in libraries as Graph 2.41.2, right down to an identical msalruntime.dll. I tested it: with Graph 2.41.2 both orders now sign in, but with Graph 2.40.0 both failures above still happen, so updating the Exchange module alone doesn’t fix anything. The fix is still on the Graph side (2.41.0 or later).

  • Satyajit321's avatar
    Satyajit321
    Iron Contributor

    This issue has been around since 3.9.0 onward modules (and again prior to that in 2.x.x versions too). Microsoft should align (the MSAL version) them with other modules as its common to have multiple ones loaded at a time.

     

    The latest version of Microsoft.Identity.Client on NuGet is 4.90.1 , however ExchangeOnlineManagement 3.10.1 loads Microsoft.Identity.Client 4.83.1 as it comes packaged with older versions, resulting in conflict with Connect-MgGraph, Connect-Entra etc. which loads\packs with 4.90.0