Skype Room System stuck on signing in (Solved)

New Contributor

Using a Logitech kit with a Surface Pro unit in it.

After setting everything up, the calendar is available, but the status att he top is stuck at "signing in". It keeps spinning the dotted progress circle, and once in a while it'll gray out the "new meeting" button for half a second as if it fails and restarts the login attempt.


The issue is occuring using a pre-existing account/ room mailbox. I tried creating a new one for troubleshooting and that works without issues. That shows the setup is OK, but we need to user a pre-existing account which already has lots of meetings in the calendar.

I tried signing in the troublesome account on another Teams Room System of the same model in another site, and that showed the same issue.

Both mailboxes have SIP/SMTP addresses set, passwords and mailbox type set, can be logged in at okay. Licensing is correct (same for both accounts).


The environment is a 365 hybrid with account migrated from local to 365, synced from local AD.


It seems the problem is account related. What could be the issue? I have compared the old and new accounts, but can't find the difference. Clarification: New account works, but I want to use the old one which has the desired name and calendar contents.



32 Replies
best response confirmed by ckoppen (New Contributor)

This problem turned out to be caused by an incorrectly set msRTCSIP-PrimaryUserAddress on the user account in local AD.


Apparently the logon to mailbox/calendar worked but not to Teams.

After correcting this, the problem went away.


Hi, we have the same Issue here and found until now no solution.

The Conference Room User can login to the Teams App without any Problems, only with SRS it does not work.
I checked also our msRTCSIP-PrimaryUserAddress on the user account in local AD and the entry seems to be ok with

What did you had to correct exactly?

Yesterday I found that having special characters (in our case ( ) , - )in the display name of the room account causes problem with signing in to Teams in TRS. Actually it signs in and everything is working but the status bar at the top with Signing in... is still there and also the display name is not displayed in the upper right corner as it usually is on the control panel.

@Par Linderoth 


I also tried to logon with my Useraccount who has no special Characters in the Displayname

Still same behavior...


@Kaya Denec Yes, unfortunately it turned out that we had some other issue (which is yet to be solved) with the account. Special characters is not part of the problem. Sorry for confusing you.

@Par Linderoth  I'm having the exact same issue. I am seeing a sign in for 'Skype for Business Online' and 'Office 365 Exchange Online' in Azure AD. All functionality is available on the Lenovo ThinkSmart 500 that I'm using but I continue to see ' Signing in... ' at the top of the screen.


I too have used an existing room account that originated as Cloud Only. It has since been synced.


Did you ever resolve the issue. I've also checked for the above attribute and it doesn't exist in AD.


Any help would be most appreciated!



@Greg Casewell 

whatever's causing this problem, it's not an account issue from my point of view.

No matter which user I try, it doesn't work with any of them to logon in SRS Teams.
I have also created a new Conference Room User, which can also log in without problems, except for SRS Teams........

I opened a support ticket at Microsoft the day before yesterday, but I haven't heard much yet.
After all, I sent all logs and now I wait until it was evaluated and I hear something from the support again. Will keep you updated if i get any solution


@Kaya Denec 


I've just miraculously managed to get this to work! 


It may be the Smart Hub being sporadic as it has been so far but if you login to Exchange Online Admin Centre and view the e-mail addresses for your room. Does the SIP address match the primary SMTP address / UserPrincipalName? 


I was reviewing this article which gave me the idea to check it:


Mine did not. The room name contained a dash. As there was no SIP address specified in EOP it appears that it was automatically generated to contain a dash. This apparently doesn't work well with SRS.


I'm continuing to test this but I can confirm the 'Signing in....' message has now disappeared! =]



@Greg Casewell Nice finding! We have the same SIP and UPN but a different primarily SMTP address. I wonder if that is causing the issue?

@Greg Casewell 

your solution gave me hope because we had different primary SMTP and SIP addresses.
I've corrected that now . Primary SMTP is now the same as the SIP address and UPN

Unfortunately SRS is still not able to login with teams......



@Kaya Denec Are you sure that the sign in to Teams isn't working in SRS/TRS? For us everything in regards to Teams is working (creating a new meeting for example) but the Signing in... info is still there. I have tried to update primary SMTP but will give it a few hours to replicate properly prior to signing in again.  

@Par Linderoth 

Still have the "couldn't sign in to Teams" Error, sign in to Skype is not the Problem, only sign in to Teams still failed.

I created a Teams Meeting for this Room User and in Fact i see on SRS the scheduled Teams Meeting, but there is no Join Meeting Option available to start the Teams Meeting. Skype Meetings are working fine....

SMTP is updated and already synced. The Information are correct now (SIP, UPN,Primary)

@Kaya Denec Ok, then we have different errors. I get Signing in... but that one stays forever even if everything is working.

@Par Linderoth 

ok and you can Join a Teams Meeting on the Device now?

@Kaya Denec Yes, everything is working except that the Signing in... bar doesn't disappear. When I put UPN=SIP=Primary SMTP the Signing in... disappeared so that was the problem I had.

@Par Linderoth 

hmmm we still have same, even we had set the UPN=SIP=Primary SMTP......
Are you in a exchange Online only Enviroment or Hybrid?

@Kaya Denec Exchange online.

@Par Linderoth 

Ok i got the problem in our enviroment, the problem seems to be the federated ConferenceRoom User who cant sign in to teams. I created a new user on o365 only, with the login adress  instead of and then it works. 


so i will re-create our Conference Room User and then it should work 



I have the same issue.

2 different system (Logitech SmartDock + Lenovo ThinkSmart Hub500) each with their unique meeting room account. Microsoft Teams Room version 4.1.22 on both systems. No AAD connect, so pure cloud accounts. SIP and SMTP addresses match.

I have the "Signing in" bar on top of the screen on both systems - but the meeting part actually works.