Microsoft Teams file preview shows black screen

Occasional Contributor

We are using Microsoft Teams on local clients (desktop/laptops) without issues. Secondly we have Teams on a 2016 RDS enviroment. In the latter one since this monday every user (+/- 50) have reported black screens in their file previews; (see attachment). 

 

If you choose to edit in the full version, online version or from SharePoint the file loads as normal, its just the preview and the edit in Teams view. Web clients also works as expected. 

Now the 'common' answer for all teams related problems; delete all files in C:\Users\<USER>\AppData\Roaming\Microsoft\Teams works, but after logging out and back in the problem returns. 

Both admins and users have the same issue.

 

In a nutshell; all users, on 6 different Remote Desktop Servers experience problems with file previews in Teams. Servers are up to date (but did not install updates this week). In the same LAN the desktops/laptops work fine. Any ideas are appreciated, otherwise ill start a case with microsoft about it.

 

 

 

 

 

 

 

 

24 Replies
I’d put in a ticket this is about the 3rd or 4th recent post about this exact issue. Something got changed recently causing this.

Hi All,

 

We have the same issue since a week or so.

Is there anybody who have already a solution for this problem?

Have you put it in a ticket by Microsoft?

I have an active ticket with Microsoft, but also we found the cause already. It seems connected to a Java update. 

 

You can check this by going in to your cache (c:/user/appdata/roaming/microsoft/teams and deleting the file settings.json

 

If you log out (just from Teams) and back in the problem should be resolved. We are currently checking what Java version is the latest working version (we made a pretty big jump in versions).

This is correct.

 

This is the solution for now.

Do you already know if this is a permanent solution?

Or is this only for one day. And when the users login tomorrow they have the same problem?

 

And when you have a final solution from microsoft will you share it here again?

That would be great.

 

Thanks

Yeah I will report back any findings. I just found out that Java was updated 3 weeks ago, but our problems started this week. So perhaps it is not the definitive cause, but it seems related atleast.

 

Ill keep digging and keep following up the microsoft case and see what we can find.

has anyone found a solution to this as currently I cannot find any information on this and its starting to cause issues with the staff and students, as they are running a server based version also

 

any update or general info would be greatly appreciated

Sorry, updates are a bit slow

 

We had a remote session and showed the problem to microsoft. Then the ticket got escalated and now they send us this solution;

 

I have engaged our Senior tier of engineers. They have suggested to start by deleting the Teams Desktop Application cache. Here are the steps:

Delete the following folders:

  1. C:\Users\USER\AppData\Roaming\Teams
  2. C:\Users\USER\AppData\Roaming\Microsoft\Teams

 

Obviously we knew this worked already, but the problem is recurring. Updated the case again and awaiting another remote session with a senior engineer. 

 see the same on windows 10 nevermind just RDS server. The preview is hosed. Seems to be related to default browser being changed and/or pdf viewer possibly for us

Hi Frank,

 

Has there been any update on this from Microsoft?

 

Kind Regards,

 

Ryan

Hi Frank,

 

Have you been able to find a fix to this issue?

 

I'm facing the same problem as well on windows 7 machines only. In our case, we've identified that the Etag value in the settings.json file might have some play in this issue as setting that value to null fixes the issue. It's only when it has a value of random characters that the black screen shows. Deleting the settings.json file and relaunching teams will give an Etag value of null but you can manually set it.

 

We set the value to null but each time we restart teams (through quitting, signing out or restarting the pc), the issue returns. It happens even though we don't use Updater.exe and use Teams.exe instead. I've gone through Microsoft Support and they've had to raise it with their product engineers. At this stage I don't have any word but when I do, I'll make a post here 

 

But for your case, has this been resolved? 

 

Thanks

Hi Bernie,

Did you manage to get a reply from Microsoft on a potential fix for this?
Hi Ryan

Yes we’ve managed to resolve it. We escalated this to the support engineers who then escalated it to the product engineers and we got a json file in return tailored for us

I admit we did continue to follow up with them for updates but support helped us really well and responded very efficiently

We are having a similar issue. I have created a website tab that connects to an announcement blog in another SharePoint site. It shows up in desktop app but not the online version. It is a blank page and Explorer give me an iframe warning/error. Hope we can resolve this as it is vital to the team.

 

iframe.png

We also realized a while ago it is caused by the settings.json file, but we are still trying to get to the root cause. Instead of a custom file we made a script that deletes the file on login as a workaround. 

 

Our current line of thought is that the problem lies in RDS environments + User profile disks. Any enviroment with RDS + Roaming profiles is fine, all with UPD's have problems. If someone can validate that line it would be helpfull. For the rest the ticket with microsoft is still going on.

We are having the same issue on most of our Windows 10 laptops for the past week or two. Deleting the settings.json file and reopening Teams does the trick for now but definitely not a long-term solution. Is it possible to share the script that deletes the file on login of Teams?

 

Also, are there any other updates from MSFT on this issue?

We have received the final, slightly dissapointing update;

 

Ticket: SRX618071292282021ID

"

There are a series of Teams scenarios that do not function properly when running under RDS.

Microsoft Teams desktop app is currently not fully supported in RDS environments.
I have double checked the information above with higher level of support and this was their final feedback; As best efforts they have also analyzed the provided logs;
We can suggest to use the Web-Client until these features are made available or use the workaround you found - deleting the cache;

You can certainly submit your feedback on https://microsoftteams.uservoice.com/forums/555103-public and help us implement that option soon;"

 

We decided not to follow up anymore after this and just use teams locally where possible and otherwise the script/webversion.

We are having a similar issue right now with multiple users in Teams client and online view. When attempting to preview a document they receive a "Hmm...looks like this file doesn't have a preview we can show you." Very frustrating for users and communicating to them that they should clear their cache isn't adequate. Please advise.

Hi guys,

we had the same problem with the black screen preview pane in ms teams on server 2016 rds in combination with citrix virtual apps and desktop (xenapp) vda version 7.15.3000.

We have opened a microsoft support case, the problem is that they cannot reproduce this issue. currently the case was escalated to development to improve the overall adaption for RDS environments. The main case was closed now because RDS is still not fully supported from microsoft perspective. 

As our users were not happy with this answer and solution and we had another problem (webcam was not recognized in ms teams on RDS), we tried to use the 32bit machine wide installer instead of 64bit. we cleaned up all profiles with the MS Teams folders and at next logon the 32bit machine installer installed the 32bit version into profile of users. since then the black screen problem and the webcam problem are gone. so the solution for us was to use the 32bit client until microsoft optimized ms teams for RDS and fully support it.

 

Hope this will help you guys aswell!