Copy not longer working in Microsoft Teams

New Contributor

Microsoft Teams gets more and more unusable. 
Newest fail is that I can not copy messages from the browser Web-App.

Honestly copy and paste is one of the daily things I need to do!  

12 Replies
best response confirmed by christian-ego (New Contributor)
Hi @christian-ego

Have you
1.) Signed out and back in (occur on multiple sessions)?
2.) Does this happen for multiple users or just you?
3.) Cleared the browser cache
4.) Tried on another Browser?

Are you using Linux? I have heard that this happens sometimes on Linux but the issue is sporadic.

Best, Chris

I have just tried to copy a single message in the Teams Web Apps and it works as expected

Re-Login seemed to solve this issue. 
But it is quite strange.

@Christopher HoardI consistently have the same issue in Firefox 67.0.4 on Ubuntu, deleting Cache and logout does not help.

Hmm I am not so familiar with either Firefox or Ubuntu I am afraid.

What is the experience like on other browsers on Ubuntu? How about Chrome? Is it any more consistent?

Best, Chris

@Christopher Hoard  Chrome is fine - I can always switch to Chrome although my preference is Firefox. I just find it curious, my colleagues have the same environment and browser as me and it doesn't affect them at all. I'm stumped as to what the difference might be.
Anyway, thanks for replying!

@Christopher Hoard 


FYI this bug is still around. You can see the root cause if you pop open the javascript console and attempt a copy:


document.execCommand(‘cut’/‘copy’) was denied because it was not called from inside a short running user-generated event handler.


Error: The copy command is not supported or enabled
undefined angular.min.js:113:36





...and you fix it how?

Yep - per normal MS took something simple and messed it up. Any idea when we will be able to copy and paste or do we just need to look at slack again?
Copy/paste is completely useless on Teams. If you want to use this feature you have to use Google Docs.



If anybody is intersted in a somewhat janky workaround. 

- Open the interface in a web browser

- select all (Ctrl+c)

- copy


I dont know why I cant copy visual selections but  that seemed to get the job done.

@christian-ego - I've found the copy and paste function is a complete lottery within Teams.

Sometimes it works fine. Others, I have to interject another app to paste into first like XnView and then copy from that into Teams. A good 50% of the time however, it simply doesn't work - nothing. No errors, no messages. Realistically nothing at all to do with file size as often it's only a few 100KBs - it's just weird.

I force Teams (and O365) to regularly check for updates - at least once a fortnight, on the solemn hope that the copy & paste function will simply start working full-time. Still got my fingers crossed on that one...