Calls not ringing through to the Desktop App

Occasional Contributor

I've read the previous article on this, it was of no help.  We now have several users all running the latest Teams client version, and both Teams-to-Teams and PSTN-to-Teams calls are failing to ring the desktop.  Mobile clients work fine for them.  They can join Teams meetings and make Outbound PSTN calls.  We are using Direct Routing as well, but because this is both Teams-to-Teams and PSTN calling affected, I don't believe this to matter.  Regardless, their TeamsUpgradePolicy has been set to Upgrade, as the users are in Teams Only mode, not Islands.


Seems to work for a while after rebooting the PC, but sometime in the next hour it quits.  Even for setting up Meetings some times has just Teams, and other times it displays both Skype and Teams.  InterpretedUserType is HybridOnlineSfBUser, and doesn't change.  WhenChanged also hasn't changed in over a week.

This is maddening.

27 Replies

@Korbyn Forsman If it's working after a reboot but then stopping, it sounds to me like some kind of network issue perhaps? If you connect a client directly to the internet without corporate security controls etc. does it keep working?

@Steven Collier it's various users, both inside and outside of the corporate network.  Also wouldn't explain the flapping the Skype meeting icon.  That had been gone for awhile, suddenly popping but up as an available option.

@Korbyn Forsman the Teams meeting button in Teams will only show if the add-in is not connecting through an authenticating proxy server. Still sounds like it's related to your network infrastructure to me. Also bear in mind that the client caches it's state for quite long periods of time, hours to days.

@Steven Collier I beleive there was an issue actually happening with MS Teams.  We also had a number of customers also report the issue or similar issues of license flapping, though nothing was posted by MS.  For a number of users Uninstalling Teams and then and only after performing a Online Repair of the Office Suite, and then Reinstalling Teams did they appear to be receiving calls through the Desktop App for a longer period of time, but still have to reboot ever now and then because the incoming calls to the Desktop App just go straight to voicemail.  I would think if it was a network issue, they wouldn't be able to IM me and tell me about it.


On the 3rd, an updated Version, came out which people, including myself, had to run the "Check for Updates" and Refresh multiple times before the client finally updated.  Seems to be better, but might still be too early to tell, many users haven't made it to the latest update yet.

@Korbyn Forsman IM uses an entirely different set of network protocols than media. You are not seeing the same experience as other people, I look after many clients and this isn't something we see, calls work as long as the network is clearly allowing UDP traffic required. If the client has failed back into using HTTPs for call traffic then all sorts of things can happen as HTTPs is often inspected, adjusted, proxied etc.


@Korbyn Forsman  I have this issue and it is infuriating


I have this issue too, I agree it's infuriating. Microsoft have become really bad at keeping the basics under control.

Our problematic client(s) today are Mac, with a PSTN calling license and the despite Teams all being set to online and available, the caller is told after the first ring that the recipient is unavailable. Does that sound familiar?
We have this issue as well, and I can't help but feel like this issue has not been recognized.
Same for me. Totally useless. All I get is the email notification of a missed call. Outbound works fine but nothing inbound to any client

@Korbyn Forsman Does anybody have an update here? It's Feb of 2020 and I'm still experiencing this issue?


@jford1280 I started working from home this week. The problem started yesterday. I tried everything suggested until eventually I disconnected from my home wi-fi and connected to my iPhone hotspot. The problem went away! 


I then removed the wi-fi connection (forget this network) and then re-established the wi-fi connection and the problem stayed fixed. I am no longer connected via phone hotspot.


For my case, it looks like a glitch crept into the wi-fi connection. 

Any update on this? Our organization is moving to Teams and we are starting to notice this issue. We are in Islands so I thought that had something to do with it but it sounds like others are experiencing it as well. 

Update - the problem reappeared. In my case it seems to be triggered when swopping between different internet links (ie home wi-fi to phone hotspot). This week I have remained only on home wi-fi and have not had the issue.

@jono101  I started a MS phone system trial and I'm having the same inbound call issue.  Problem persists regardless of which network is used - wired, wireless, or verizon hot spot.  Did you make any changes to wifi router or network settings to get it working?


@JGardella I had to remove all trace of Skype to get it to work. Nothing to do with the network.


It should also be noted that if you're "collaborating" as a guest in someone elses org, you won't be able to receive (or make) calls. It's all a bit rubbish!

@James_Baly  I was able to resolve my issue.  It tuns out my Teams upgrade status was set to 'Island'.  I set it to 'Teams Only' and within an hour calls stated working as expected.


Thanks for the updates. The issue resolved itself when I move back into the office onto our work network. Your 2 tips about removing skype and checking Teams settings are good to know if this occurs to me again in the future. 

Updating this for others. It is by design that Teams PSTN features don't work while in "Island" mode. Only Skype will receive and get calls. You can call outbound on Teams, but inbound def won't work, plus other features also won't route properly.


@Techlogik Thanx for your reply, I was checking on this problem for hours and your post solved the problem for me!