Software Center Crashes after approx 30 Minutes - HP EliteBook 640 G9

Copper Contributor

Hi All,

 

We have started to buy in a new model of laptop (HP EliteBook 640 G9) and have used the standard Gold Build we use for all other devices (deployed via OSD TS) on the device. For information, this error is not happening on any of our other models after a new build or even during current operation.

 

After the build, we then log in to the device to start configuring and allowing the software / updates to deploy to the device via Software Center. When Software Center has been left open for approximately 30 minutes (sometimes a little longer), it will suddenly stop working and display this message:

Annotation 2023-11-07 074850.png

I have checked the SCClient log and the main messages I can see before it happens is as follows:

Exception caught in OnGetException, line 193, file C:\__w\1\s\src\SoftwareCenterApplication\App.cs - Type System.Runtime.InteropServices.COMException: UCEERR_RENDERTHREADFAILURE (Exception from HRESULT: 0x88980406) (Microsoft.SoftwareCenter.Client.SingleInstanceApplication at OnGetException)

 

StackTrace: at System.Windows.Media.Composition.DUCE.Channel.SyncFlush()
at System.Windows.Interop.HwndTarget.UpdateWindowSettings(Boolean enableRenderTarget, Nullable`1 channelSet)
at System.Windows.Interop.HwndTarget.UpdateWindowPos(IntPtr lParam)
at System.Windows.Interop.HwndTarget.HandleMessage(WindowMessage msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

I have completed the following based on information I have found when searching the error:

  • Rebuilt WMI
  • Reinstalled SCCM Client
  • Repaired SCCM Client
  • Updated Graphic Drivers
  • Checked version of .NET is up to date (latest version of 4.8 installed)

I am now unsure what next to try and would appreciate any help you may be able to give.

Many Thanks,

Richard

5 Replies

@A1 thank you for the link, but I have already reviewed this and completed the steps and checks that were advised in this, with nothing seeming to resolve the issue. 

 

As I advised I have completed the following with no success, which seems to me to cover all of the options from the article:

  • Rebuilt WMI
  • Reinstalled SCCM Client
  • Repaired SCCM Client
  • Updated Graphic Drivers
  • Checked version of .NET is up to date (latest version of 4.8 installed)

@A1

 

Thank you again for the link and it does seem the issue is similar. Unfortunately it doesn't really provide a valid resolution as we are not seeing the same issue on every device.

We have however just built a new model of desktop yesterday and this is showing the same issue when Software Center is open for a longer period of time.

 

It could be something new in the HP devices we are purchasing, but I cannot figure out what, or could it be related to a new update.

 

I really am not sure and have search the internet for an answer with no success so far.

@Richard_Ward 

Maybe it's better to ask in the Microsoft Q&A – that seems like a more appropriate place.

or open a Microsoft support ticket.

Good luck