18362 Upgrade failed due to 17763 Microsoft XPS and PDF drivers?

New Contributor

My Release Preview Ring 1809 (17763.404) computer can't upgrade using Windows Update directly, every time it run 100% and told me restart to install 19H1, never jumped into install screen, and the 10GB migration \$WINDOWS.~BT\ just disappeared, then the Windows Update just start over again, to break the loop I tried to install it on uupdump ISO.

After checking comparability ("Make sure you are ready to install") it says:

This PC can't be upgraded to Windows 10.
Your PC has hardware that isn't ready for this version of Windows 10. No action is needed. Windows Update will offer this version of Windows 10 automatically once the issue has been resolved.


In $WINDOWS.~BT\Sources\Panther\CompatData.xml it says:


<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem20.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem59.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem71.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem87.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem44.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem42.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem16.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem124.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem24.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem70.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem116.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem19.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem77.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem102.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem64.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem106.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem34.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem6.inf"/>
<DriverPackage HasSignedBinaries="False" BlockMigration="True" Inf="oem93.inf"/>
<DriverPackage HasSignedBinaries="False" BlockMigration="True" Inf="oem92.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem39.inf"/>
<DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem2.inf"/>



So the drivers blocking Upgrade are C:\Windows\INF\oem92.inf and oem93.inf

Microsoft Print To PDF
C:\Windows\System32\DriverStore\FileRepository\prnms009.inf_amd64_80184dcbef6775bc (ver.20180915)
Microsoft XPS Document Writer
C:\Windows\System32\DriverStore\FileRepository\prnms001.inf_amd64_f340cb58fcd23202 (ver.20180915)


I can't update those printer drivers which Windows Update already got those 18362 new drivers








I've tried delete those printers but still can't pass comparability check, since those drivers are still in C:\Windows\ after uninstall printers.

10 Replies
best response confirmed by visa1901 (New Contributor)

I continue to receive this error even after removing those two virtual print drivers with pnputil.
There are no blockers but it still blocks.


UPDATE: Apparently if you use pnputil to remove those virtual print drivers, then delete compatscancache.dat in the Panther folder, then hit back and rescan, it'll then work.

@Inari Okami Did you successfully installed 18362 after deleted compatscancache.dat?


I removed those printer drivers using Control Panel > Turn Windows features on or off. The log don't have anymore driver block the migration, but still get "Your PC has hardware that isn't ready for this version of Windows 10 ". 


Before I tried 18362 uupdump converted iso, I tried the official insider ISO build 18343, and my PC passed the compatibility check in 18343, installation run to 87% then failed. setuperr.log was pretty mess. I believe is said


Error CONX 0xd0000034 Failed to add user mode driver [%SystemRoot%\system32\DRIVERS\UMDF\uicciso.dll]


@visa1901It did successfully install, yes. For some reason it was still detecting it because of the stale cache file.

@visa1901It did successfully install, yes. For some reason it was still detecting it because of the stale cache file.


I'm also using a uupdump based ISO.



How did you find what driver oem92.inf  points to? I'm having a similar issue but my ScanResult/CompatData says oem123.inf and oem122.inf are blocking the upgrade. What are these drivers?



Ok, I found the driver names with this command:

pnputil /enum-drivers


and they are printer drivers from Microsoft as old as from 2006...

@tmxkn1 If it's the same virtual print drivers, they can be temporarily removed from Control Panel -> Programs and Features -> Turn Windows Features on or off -> mid-way down, Microsoft Print to PDF and Microsoft XPS Document Writer.


Simply opening each INF listed as a blocker in C:\Windows\INF will also tell you exactly what they are at the top of the file.


2006 is the listed driver date of most official inbox Windows drivers, as the date allows OEM drivers to automatically override them if they're newer. It doesn't mean they're actually that old.

Yes they are the same print to x drivers. After disabling them in "Turn Windows Features on or off", I have to manually delete the "compatscancache.dat" too as you mentioned in the accepted answer.

@tmxkn1 You can also open the file from C:\Windows\Inf\oemXX.inf and it will say what device the driver is for.

@Andrew Porter 


c:\windows\oem0.inf and c:\windows\oem1.inf are causing the issue


Delete c$\$WINDOWS.~BT\Sources\Panther\compatscancache.dat if it exists

Remove-Printer -Name "Microsoft XPS Document Writer"
Remove-Printer -Name "Microsoft Print to PDF"
Disable-WindowsOptionalFeature -Online -FeatureName Printing-PrintToPDFServices-Features

Disable-WindowsOptionalFeature -Online -FeatureName Printing-XPSServices-Features 
pnputil /delete-driver oem0.inf /force
pnputil /delete-driver oem1.inf /force