1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's

Brass Contributor

1703->1709 BSOD 0xc00000bb on devices with NVMe SSD's


This will be the very first question I will ask in the AMA.  I hope you have a better answer than "we are working on it" ready for the thousands of us with this issue and waiting for a fix since September.

222 Replies

Hi Michael, first thank you for following up and not leaving us hanging.


Second, Yes, mine is a custom built X299 based system.  The motherboard is the ASUS Prime X299-Deluxe and the SSD is the NVME Samsung 960 Pro M.2 512GB.


I have checked with both ASUS and Samsung and neither have posted a recent firmware update to address this issue.


PS:  You mentioned a block in place to prevent the installation.  I can tell you, if it is designed to block the 1709 installation via Windows Update, it is not working for me.  Every time I check for updates it tries to download and installed the "Windows Feature Update to 1709".  I've had to temporarily disabled the Windows Update service to prevent this from happening every time.

Yes, the Asus board is the most common one.  It's a pretty subtle issue, only exposed by 1709 due to a slight increase in the boot image size (which is why previous versions worked fine) that results in the boot image being loaded into higher memory due to memory fragmentation on that specific motherboard with that specific firmware.


I'll check to make sure the block is correct.

Interesting, thank you for explaining the detail of the problem.


We remain hopeful for a fix soon.

I have an ASUS Prime X299-A motherboard with a 512GB Samsung 960 Pro SSD and two SATA drives, as well.   Right now Windows Update has been trying to upgrade me to 1709 for about a month now.  I have my ethernet connection set to metered so it does not download the update.  I have kept my 1703 system updated with manual updates I downloaded and installed myself. 

I have tried with an ISO flash drive, Windows Upgrade Assistant, etc. to upgrade about a dozen times and every time I try to reboot I get the BSOD with error 0xc00000bb.  If you need any other information I will be happy to give it to you.  Thanks. 

That is amazing I have almost the identical system except an ASUS Prime X299-A MOB, and I have the identical problems as you do.  I also have had Windows Update trying to update me for weeks.  I had to change my connection to metered to prevent Windows Update from downloading the update.  

 Hi Michael


I tried the 30 November update (KB4051963) right now, but my pc still crashes after the installation reboot.


After I tried the Upgrade my PC restarts, the screen stays black for around 2 minutes and then the PC does power off. When I start the PC again, it immediatly boots with Build 1703.


Machine: Selfbuild

MB Modell: MSI X99A Gaming Pro Carbon (LINK)

SSD: Samsung SSD 960 Pro nVME


Is the X99A also affected with the same problem as X299? Or is the Samsung 960 Pro still not patched?


This may also affect other motherboards.  The Asus one is the one that we have seen most.

Could it be that ASUS is just the most popular motherboard ?  I have seen people with MOB's like MSI and Gigabyte with the same problem. 

I'm also having this issue. I have a Samsung 960 pro and asus prime x299 deluxe board.

That seems to be the magic combination with this problem: An ASUS X299 MOB with a Samsung 960 Pro SSD M.2 using NVMe . 

Also having this issue. System specs:

MOB: Asus prime X299-deluxe (FW: 802; running 28 lanes with i7-7800x & quad memory)

SSD: Samsung 960 evo M.2 500GB (NVMe, FW: 3B7QCXE7)

Signed up to add my similar experience, have several friends with largely same spec.

Same issue with 1709, same spec : Asus Prime X299 Deluxe. Samsung 960 Pro 2TB m.2.


Also, the 1709 update is also not blocked for me ( has failed 9 times, and is currently waiting for a reboot which I guess would fail). My machine is a standard build by


It's odd that a clean install reported to be be OK, and yet an upgrade is not. 


Thanks in advance for any help.


Also tried everything possible but a clone & fresh install because i don't see why i'd have to resort to that.


Windows upgrade assistant seems to have messed up my pc even more.


From  BSOD 0xc00000bb  update failing to Error 0x80242006 every time my pc tries to automatically update itself.


Motherboard: MSI GAMING M7 ACK

SSD: Samsung 960 evo + Samsung 960 pro 


Also a friend of mine has the same SSD's as myself but with a Gigabyte X299 AORUS Gaming 9 & has the same problems.


I have also heard of countless people with different model Motherboards that have this problem.  It is not just ASUS.  Gigabyte and MSI Motherboards all have this problem.  The common thing all of us seem to have that have this problem is the Samsung M.2 NVMe SSD. 

I to have been having this issue with an X99-A MSI board built by Origin with:

MSI Godlike Gaming Carbon

w/ Samsung 960 Evo NVMe and a Samsung 850 SSD


The update appeared to have issues and recently seemed to try to auto update itself hosing my install to be stuck on a blank boot screen, no amount of repairing startup fixed it so I went back to a recovery USB from Origin.


I seem to agree with the group here that the common denominator seems to be the 960 NVMe but that could just be that its a common NVMe drive. 


Considering its already hosed my install and I've gone back to a blank 1703 install I may try some of the workarounds to get to 1709. What's frustrating to me right now is that the Windows Update is stuck wanting to install 1709 so bad that because its failed on restart theres no way I can see to force it to redownload updates or check for new ones. I've gone so far as delete the download files expecting it to check and attempt redownload. Nope, still thinks its there and still thinks it wants me to restart thinking it will install.


I attempted to use the Microsoft tool again to download the update on Wednesday and it didn't seem to pull any new updates as it ended in the same error on install.


Another odd thing is that for the first time I've had my overclocking profile fail twice after shutting down the PC and on the next boot up the next day it fails, I reload the config and it's fine. All hardware checks out. Just odd. No issues until this 1709 stuff started.

I have the problem as well, and have not noticed any block.

Now I turned the automatic update off, since my PC tried to update at least 10 times, consuming all network bandwidth.


This is my config:

Samsung 960 EVO SSD M.2 2280 - 500GB

ASUS released an updated bios (1004) for the Prime-X299-deluxe today that fixed the issue for me.

Where do you see that bios revision ? I'm on the asus support website for the X299 deluxe and I'm still seeing the 802.

Never mind I just found it under others in the os selection.


I can confirm that this fixes the issue for those with the Asus X299 Deluxe board. I'm now on the 1709 version.

The 1004 BIOS Update DID NOT fix the problem for me.  I just wasted an hour attempting the upgrade using the Windows 10 Update Assistant and it failed with the same BSOD.


ASUS Prime X299-Deluxe

Samsung 960 Pro NVME M.2 SSD