Tech Community Live: Windows edition
May 31 2023, 07:30 AM - 11:30 AM (PDT)
Microsoft Tech Community

Print Jobs not stable

Occasional Contributor

Hi All, 


I am facing some trouble with getting Universal Print to work properly so I can enroll it to our organisation. 


The main issues I am facing are having to do with the actual printing the connector now work without issues and I can register the printers without issue also. But as soon as I start printing I am facing random issues. 


Last week the prints went perfect for myself and the test printer. So I decided to add another printer which is in another physical network to see if I could also print there. This resulted in the print getting automatically aborted by the Windows Print Queue and also in Universal Print.


From that point on I tested the old printer again that was working fine and I had the same results all the jobs get aborted. 

Seeing as that was Friday I figured lets try it again after the weekend maybe something has changed and indeed it has. All of a sudden my print jobs now stay pending. Windows says it has been send to the printer and universal print says it is pending. 

I am currently on the same network as the printer I am testing with.


This happened before and at that point I registered the printers again with an update of the PrintConnectorApp. From that point it worked for a few days and then all of the above happened.


What can I do to figure out where the issue is? Cause the main think I am lacking is feedback of what goes wrong so I can try to fix it. 


Thanks in advance!


Kind Regards, 

Johny de Koning

8 Replies

@Johny_de_Koning sorry to hear about your experience. What version of connector are you on? Is it same as the latest version on

If system continue to be unstable, I recommend you to reach out to Microsoft Support via Azure Support portal.







Thank you for the mail the version of the connector was 1.4 and I just updated it to 1.10 but the result is still the same. There is nothing currently printing they all stay at pending. 


Is there anywhere I can find some information of what is wrong? Cause I haven't really seen any logs or feedback or so, but I just might be missing it.


Thank you again.


Kind Regards, 

Johny de Koning

@Johny_de_Koning - we will really love for you to file a Azure Support ticket as per the link provided earlier, and help troubleshoot the issue.



I have raised a ticket thank you so far.

@Johny_de_Koning I would like assistance too this is really impacting my company now we have deployed a very large group of printers

@CSanchez1285 when I get a reply from the ticket that solves the issue I will let it be known here so others might use the information. 

@CSanchez1285 The issue for us was that I removed the local printers from the machine with the Connector. And by doing that there is no connection from Azure to the printer (this goes through the connector). 


As soon as I installed the printer again and waited a few hours for everything to sync it worked again. So now I am going to get a dedicated machine for the test where I just leave everything on. 


If this doesn't solve the issue I suggest you raise a request.

I@Johny_de_Koning I was able to talk to a rep and it turns out the Print drivers needed to be updated as this was causing major issues. If anyone sees this update to the latest drivers (mine were all HP machines) and this resolved it! There a method to update the drivers in microsoft universal print driver documentation.