flow run failed - The specified object was not found in the store

Iron Contributor

I create a template from Microsoft for a check on a shared mailbox and then add the attachment to a Microsoft Lists (SharePoint Online).

I go to do a Test, manual, and it errors out.




When I click, it says no mailbox found.



That is frustrating as when I go to create a new, I type in say the name "sharedMailboxaname" and AAD resolves it, yet the Inbox doesn't 'exist.'




The dynamic invocation request failed with error: { "status": 404, "message": "The specified object was not found in the store., Default folder Root not found.\r\nclientRequestId: f12cdb6f-1ead-4807-b978-6120a051cc3a\r\nserviceRequestId: 02e88b74-827d-43ea-a768-70351841738d", "error": { "message": "The specified object was not found in the store., Default folder Root not found.", "code": "ErrorItemNotFound", "originalMessage": "The specified object was not found in the store., Default folder Root not found." }, "source": "office365-wus.azconn-wus-01.p.azurewebsites.net" }.




Again when I go to manually test it, it errors out.




The specified object was not found in the store., Default folder Inbox not found.





  "message""The specified object was not found in the store., Default folder Inbox not found.\r\nclientRequestId: 6f62c224-a3f5-4db3-bceb-4e8f512a3834\r\nserviceRequestId: c4b6d9a7-3f7c-4b95-9151-e04beb370bce",
  "error": {
    "message""The specified object was not found in the store., Default folder Inbox not found.",
    "originalMessage""The specified object was not found in the store., Default folder Inbox not found."
  "Strict-Transport-Security""max-age=31536000; includeSubDomains",
  "Cache-Control""no-store, no-cache",
  "Date""Thu, 09 Jun 2022 22:10:38 GMT",
When I go to Exchange Online it shows that it is SharedMailbox.  We are in hybrid mode and it was created in Exchange On-premises.
Exchange on-premises shows it.
This was setup exactly as another mailbox and it works.  I am not sure what is happening that I can see it, email to it and have it as a shared mailbox on my Microsoft Office 365 Outlook.
Thank you.
4 Replies

@Matthew Carter 


Found that I went to Exchange Online and add a shared mailbox:

I created one called test and added it and then I was able to go in 





Ran a test on Power Automate and it worked.  The error is that the file has already been DELETED from the mailbox, so it can't delete what is not there.




The file goes into a Document Library in SharePoint Online




Not sure WHAT the issue was, made a new Shared Mailbox and don't know what happened with the first one, maybe the name had an issue.



Same error. Discovered that a connection reference had been adopted which didn't have permission to the mailbox. Changed to one that did. All good
This "Default folder Inbox not found." error was beyond frustrating. I think it appeared because I made the Flow *before* adding the logged-in account as a member of the shared mailbox.

To fix, I:
1. Deleted flow(s) trying to make the connection to the Shared Mailbox
2. Deleted and Re-created the shared mailbox with the exact same email address
3. Immediately added my Microsoft account (the one I'm using to make the Flow with) as a Shared Mailbox member
4. Opened the shared mailbox at Outlook.com by clicking the profile picture > Open another mailbox (& refreshed)
5. Recreated the Flow
I found an maybe even simpler fix: Ensure the user has permission to see and send as the shared mailbox account, then send an email to the shared mailbox as the shared mailbox. Solved it for me.