OneDrive "Copy" button cannot copy the share link to clipboard

Copper Contributor

Hi All,

The OneDrive "Copy" button is not work when sharing a file, it can't copy the share link to clipboard. I have to manually highlight and copy the shared link using Crtl-C.


The OneDrive version I am using is 22.207.1002.0003. Also, I tried to install newer version 22.212.1009.0004, but cannot resolve the issue.


I think I have the same issue as this one:






10 Replies
Same problem here, looking forward for a solution.

I'm having the same issue. Tried reinstalling OneDrive with the latest version. It worked for a couple of days and then stopped working again. 


Build 22.225.1026.0001




This issue seems to be fixed with OneDrive Build 22.227.1030.0001


All you need is to follow below steps

  • Open OneDrive Settings > About
  • Tick the box Get OneDrive Insider Preview updates before release,
  • Close OneDrive and open Windows security
  • Under Virus & Threat protection > protection updates and check for the updates 
  • This should be higher than the Security intelligence version: 1.379.466.0 
  • Re-open the OneDrive,
  • Share the the file > Copy Link > Create link and Copy button should be working


@Ashish_Bhaduwala Thanks for this, I've tried it and got Defender definition up to date and onedrive to same version as mentioned, but problem is still there. Will try same on another PC

This fix works on windows10 or 11 update 22H2.
The 'Copy' button is working today. Haven't did anything, just work.
Same here, the issue just stopped occurring. I did not upgrade the version to Build 22.227.1030.0001 as @Ashish_Bhaduwala suggested.

Thank you for this! I read your comments/solutions and post suggestion feedback and I think I am going to reboot my computer and hopefully it will solve itself. 

@Milagros_MillieR Sorry, I realized I made a typo in my last comment. I meant I DID upgrade the version