Stream video is showing authenticated user not reauthorized to view the video message for owner

Occasional Contributor

Hello team,


I am new to Office 365 community , we have Office 365 A1 licenses for our school. One of our faculty has two videos first one getting played perfectly without any issues but the second one is showing below message to everyone includes owner of the video and global admin of the O 365.




Second thing to fix this I  tried to open the Stream in separate browser as global admin, it is not allowing me to access the ADMIN settings , I am missing that option in my profile and its showing as blank screen as below.  




also when I am trying to create new video channel its not redirecting to desired page just staying same page. 

when I am trying to add a working video to a existing channel it is saying like below which is worked last two days perfectly.




However I am not sure , can we access the full functionalities such as accessing videos / uploading videos / creating the new channel  in Stream with Office 365 A1 License.


Your all help is much appreciated.





6 Replies
best response confirmed by reachuslittleroboz (Occasional Contributor)

@reachuslittleroboz  Welcome to the Microsoft Stream community!


What you describe should work with your license. Please try to use a new incognito session with your browser or delete all cookies just to check if there are not problems with multiple or different accounts. You must verify that you use the right user for the tenant. Stream has no guest access and the URL for accessing a video in Stream does not change or identifiy "your" tenant.

And check if the video is published. If it is a Teams meeting recording, check the meeting for error messages to the video.

@Tomislav Karafilov 


Thanks a lot for your solution directional response.

Yes , it is working perfectly in incognito mode, I was working with multiple user base and it was not worked properly for me and after your advise it is working as expected.


However still I am having an open issue with one of the meeting video ( which I mentioned in my earlier post) is still not playing and showing the same error message.  I did not find any exceptions in meetings notes and it is published on the meeting chat as below when we try to play  its showing message as "no authorisation for authenticated user" 


Published like below 



after trying access it to play 





Thanks for your support. 


@reachuslittlerobozFirst solved :smile:!


Second: The second screen shot seems to be from inside Teams desktop app. Right? Can you see the video in the Stream web site or when using Teams in browser? We need to find out if there is a problem with the app/browser or with the video itself or with permissions. So what app do you use and what permissions are set in the video details?

@Tomislav Karafilov 


I am not using any desktop apps, I am accessing teams & stream both are from Browser.

I have problem with one video rest of all videos are playing good. 


This particular video is from one of our Teams meetings, i can only accessing this from teams. Its not showing even in Streams - discover - videos options. I still believe something went wrong with permissions.



@reachuslittleroboz  Is it visible under "My content / Meetings"? If not, try the admin switch, if you are an admin, else ask the admin to do this. If you can see it in Teams, it is stored in Stream. Can you access the permission tab?

when i reported this in exclusive menu options of video from CHAT - REPORT VIDEO , the next day it is started working.
Appreciate your help friend. Thanks a lot