Most O365 groups not visible in Stream

Copper Contributor

We have a hybrid Exchange environment, so on-prem AD with AD Sync to Azure.  We have a couple dozen O365 groups outside of AD, in "cloud" mode, and those are functional in Sharepoint and Teams.  However, in Stream, going to Discover, Groups... we can only see about seven of the O365 groups.  The rest are simply not present.  I am doing this as a global admin.  I can work with the visible groups as expected... I just can't see/use the rest of our groups.


Attempting to add a group with streams when the same group name already exists in O365 recognizes that the e-mail alias is in use and won't proceed, as expected.


There doesn't seem to be anything in common between the groups that are visible in Stream.  I can't find anything different between groups that are visible and those which aren't when I look at all the properties in Azure AD.


Further, when creating a channel (outside of any existing group), we cannot pick existing groups in group mode (as opposed to company-wide).  Even the ones that show up in Discover are not available via search when creating a new group in group mode.


Everything I'm reading about groups in Stream seems to indicate our O365 groups should "just work", but I'm not finding that to be the case.


Any insight as to what my non-visible groups need in order to start appearing within Stream so I can create channels within them would be greatly appreciated.

11 Replies

Any update? Same issue over here...


Same here. It seems to be haphazard which O365 Groups make it through to Stream and which never get created. If only there was a way to kick it off manually... Any Powershell commands???

@B_L_A_I_R  I have a ticket open with MS for this. They've been working on it since 9/16. I've been told it's with development and will hopefully be resolved soon. Lots of pressure on this ticket, so I'll reply back when confirmed and what the steps were. If you want to open your own ticket, reference 16569717.

@Justin HorneHi Justin, Any update on this issue? I am now experiencing the same problem.

MS was able to fix it on their end. Open a ticket and reference the one above.
We had same issue until I read somewhere that O365 groups are available in the People drop-down, not the Groups one!
All my groups are available there
Seems the Groups selection only relates to Stream groups
Downside now is that it seems you can't create a Channel without a Stream group


I have had the same issue and in browsing came across your post, I have however had a little success.  I noted I could see groups for which my account was a group owner.


In testing this I found that despite being a global admin, and having admin mode enabled I could still only see O365 groups my admin account was an owner of.  I switched to my non-admin account and could then see different O365 groups for which that account was the owner (like planner groups etc.) 


This suggests that there is perhaps a lookup / read issue in that when in stream even as admin you can only see existing O365 groups which the currently signed in account owns. 


I've also tested this by adding myself into an existing group as an owner and after waiting for it to sync was then able to see that group when creating the restricted team channel.  


Has anyone else tried this / had the same experience &/or know if directly assigning stream admin rights (over say global admin) make a difference on this?

Hi !

Any update  ?

I encounter the same issue

Thanks for your help


Make sure that the O365 Group that you are trying to add has an MS Teams. You can go to Office Admin Center and click on "Create Team" (see screenshot). After that, you should be able to search it already in MS Stream when adding it on a channel. 




Is this still an issue?  I cannot see groups in Stream that are setup the exact same way and I am an owner of both groups in O365.  The groups both have teams. I have tried switching from personal to admin mode in stream with no success.



This is still an issue!

O365-groups created outside of Stream periodically don't show up in the Stream-Group-List.

Please fix!