Microsoft Stream will not load in Chrome

Brass Contributor

In Chrome, when I click Stream from the homepage, it will hang up on the Stream Red Arrows (loading) forever. I tried clearing my cache and it still does it.


It works fine in Edge and Explorer. Any thoughts on what to do here?

19 Replies
That's very strange...I use Google Chrome regularly with Office 365 including Microsoft Stream and I have never seen those problems when accessing Stream so I recommend you to open a support case here.
I was having some problem loading a video as well. I disabled an extension that was preventing the page from loading. Maybe worth a try to see if a privacy or ad blocker is hanging it up?

I am getting the same problem. Sometimes i can log in but there is nothing available to click. it will tell me you need to refresh your browser but that doesnt change anything @RJ Miller 

@Shawn Salamipour  - This issue seemed to resolve itself for me. For a while, I just used a different browser. Now it works fine in Chrome again. I'd suggest upgrading Chrome

@RJ Miller  I had this exact problem for the longest time.  I tried removing extensions, hard load and refresh, but nothing was working.  I finally got it resolved by following the steps:


  • Launch Developer Tools and select the Application Tab
  • Expand Local Storage, right-click on and select clear
  • Expand Session storage, right-click on and select clear
  • Expand cookies, right-click on and select clear
  • refresh the page

After following these steps, stream is now up and running again for me in chrome.  Hope that helps.

@Jace Copier thanks for the tip. Your steps worked for me as well.

Worked a treat!

@Jace Copier Thank you! Fixed. Finally.

@Jace Copier  Working fine, Thanks

Thanks a ton, that worked like a charm. MIght want to add to your step by step that it's now called "Application" ribbon now. :)


 @Jace Copier 

@SVibe thank you.  I have updated my steps to reflect the change.  

@Jace Copier Thanks for this.  I managed to solve this too.


To open developer tools click on Ctrl-Shift-C then follow the steps!

Awesome thanks!

@Jace Copier This didnt resolve issue :(

Me too

@Jace Copier 

None of the advise has worked for me. I am still stuck in the beginning. I have to watch a video intro about the service. When the video ends, nothing happens. no option to continue. 

@Jace Copier  You're my hero - thanks so much!  :smile:  Stream was stuck on loading for Chrome and Edge...finally had to sort out and found your post...worked like a charm in both browsers! Thanks again - cheers!

Outstanding, worked like a charm!@Jace Copier 

Even after proceeding all these steps it is not working.