Windows Hello for Business prompt after Hybrid Azure AD Joining Win 10 Device | WHFB disabled

Brass Contributor



I'm looking for some clarification on the behaviour around Windows Hello for Business after Hybrid Azure AD joining Windows 10 devices.


I recently enabled HAADJ in AAD Connect.  As expected first of all, the devices acquire a userCertificate attribute as part of the WorkplaceJoin schedule task, sync to AzureAD as part on the next AADConnect sync cycle and show up in the Azure AD tenant as a HAAD device.


The issue I encounter is with the Windows Hello for Business prompt.  When a synced user logs in, they're prompted to setup a Windows Hello for Business PIN.  You can skip the process and continue but every subsequent login ask you to set-up a PIN which you can sync.


The devices are HAADJ but not enrolled into Intune for MDM.


In the AzureAD Portal under Microsoft Intune\Device Enrollment\Windows Enrollment\Windows Hello for Business, it was set as Not Configured.  I also changed this to Disabled, but the users still get the prompt.


I only way forward I'm finding to deal with this is by setting the settings “Use Windows Hello for Business” under "User Configuration\Administrative Templates\Windows Components\Windows Hello for Business” to Disabled.  It was previously set to Not Configured.  This stops the setup PIN prompt coming up after login, however, notifications still appear in the notification area after login saying that The system is configured to use Windows Hello for Business,  Click here to setup you PIN.


I do not get this behaviour in other environments where I have HAADJ configured, with seemingly the same settings.


End goal is wanting to retain HAADJ but disable all the prompts for setting up Windows Hello for Business.  Any ideas?


12 Replies
Very strange. I have exactly same setup but I don’t get your experience.
Do you have Security Baseline or Windows Config profile in place that somehow pushing the setting? There are multiple places that you can enable WHFB in Intune.

@Moe_Kinani I know, very odd. 

The devices are only becoming Hybrid Azure AD Joined, I'm not enrolling Windows devices into InTune.  If I check InTune devices, there's no devices showing, as I'd expect.


I have not encountered this on other installations with the same scenario.  I'm wondering if it's something specific within the AD forest environment I'm deploying into causing this to occur, opposed to the Tenant side setting but can't see what.

I checked security baselines and windows configs in InTune and there's nothing assigned.  However, I would only expect that to take effect if the devices/devices were InTune enrolled.

The only way forward have found so far is scoping a GPO which scopes the setting Use Windows Hello for Business to Disabled under User Configuration\Administrative Templates\Windows Components\Windows Hello for Business.


Just looking at the logic as why when Use Windows Hello for Business is set Not Configured devices are prompting the user to set-up a pin after domain login. 

Some example screenshots below.

Very clear. Thought you had the devices enrolled to Intune.

Not sure if you have Intune license but worth try to enroll the device with Intune and disable WHFB by Config profile and scope it to the computer. I’m presuming this scenario because you are certain no Local GPO applied to enable WHFB.

Thanks for the idea.

I'm pretty certain that the Use Windows Hello for Business setting is set to Not Configured as standard for Win10 devices.

The curious part is I haven't seen this issue before on other set-ups where HAADJ is enabled and WHFB is set to disabled or Not Configured under Windows Enrolment.

I'm going to continue with amending the WHFB setting by domain GPO for the time being, as opposed to enrolling into InTune for modify the setting. They'll essentially achieve the same outcome.

Any other ideas welcome as to the WHFB setup PIN comes up when 'Use Windows Hello for Business' setting is set to 'Not Configured' as standard for Win10 devices.



Managed to shed some light on this.

In short, ignore the WHFB settings in InTune unless the device is MDM enrolled and managed by InTune.  Essentially this was the associated to a group policy via AD on premises which was already in place for the AD forest/domain.

There was a COMPUTER GP in place which set "Computer Configuration\Administrative Templates\Windows Components\Windows Hello for Business” to Enabled.  I imagine that somebody switched it to enabled thinking that would be nice to have.

After enabling HAADJ, a device was becoming hybrid joined, and the subsequent login (from a synced AD user) resulted in a WHFB Set-Up PIN prompt.

If the "Computer Configuration\Administrative Templates\Windows Components\Windows Hello for Business” setting been set to Not Configured, this wouldn't have arisen as an issue.

As a note, once we had set the "User Configuration\Administrative Templates\Windows Components\Windows Hello for Business” to Disabled, that took priority over the Computer Configuration policy and the WHFB prompt didn't show.


So lesson learnt is to check those GP settings in an AD on premises prior to mass syncing devices to be Hybrid Azure AD Joined.

hi Ben

I am facing the same issue can you guide me on this issue. how you are resolved the issue i have the hybrid ad setup post enrolling of the device windows hello prompt appeared on the user login screen
till now i have disabled windows hello in the intune portal and one of the GPO is configured windows Hello Enable i have marked as a not configured.
is there any other changes i have to do stop the prompting user for windows hello prompt
ok after disabling the gpo it will not prompt for the Hello Pin prompt at startup right ?
I believe so. This was a long time ago, so my advice would be good through my post dated ‎20-03-2020 and follow the advice there.
thanks i will check, below one more config i have made in the intune
i have set false at use passport for work. i will update if it works

@Vijay2744 just wondering if you have tried to disable the GPO and if it worked?

I’m having exact same issue now.

yes after disbaling gpo it is working for me