CompanyMultiNationalEnabled for AAD

Iron Contributor

How I can configure CompanyMultiNationalEnabled for my AAD? When want to set it up with Set-MsolCompanyMultiNationalEnabled it gives me an error.




5 Replies
What error are you getting?

You need the version of the MSOnline module:


And, this is still in Preview, so I'm not sure it's available for everyone just yet.

This is the error I get.


PS C:\temp> Set-MsolCompanyMultiNationalEnabled -ServiceType "SharePoint" -Enable $True
Set-MsolCompanyMultiNationalEnabled : The operation to invoke SetCompanyMultiNationalEnabled is not allowed. The service for service type 'SharePoint' does not exist, or this service does
not support any data location, or this service does not support multinational company feature for company 'd1794c7e-c5bd-4cb5-97d8-a24c2d32e2e2'.
In Zeile:1 Zeichen:1
+ Set-MsolCompanyMultiNationalEnabled -ServiceType "SharePoint" -Enable ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : OperationStopped: (:) [Set-MsolCompanyMultiNationalEnabled], MicrosoftOnlineException
+ FullyQualifiedErrorId : Microsoft.Online.Administration.Automation.OperationNotAllowedException,Microsoft.Online.Administration.Automation.SetCompanyMultiNationalEnabled

Same problem here... I've download the AzureAD in preview and also I tried with the old console with the same result :(


Could be that this option it is only available in NAM? My tenant is also in FR


Also, to try to give more light to this weird problem, if I try to execute the following command: 




The result is empty, any help would be appreciated

I'm seeing the same thing. Running on version of MSOL