Microsoft Entra Suite Tech Accelerator
Aug 14 2024, 07:00 AM - 09:30 AM (PDT)
Microsoft Tech Community

Azure AD PowerShell v2 cmdlets not working, e.g. Get-AzureADPolicy

Copper Contributor

Sorry if I posted this twice, to me it seems that the first post did not succeed.

Installed PowerShellGet using the MSI.

Installed the Azure AD PowerShell v2 GA module using Install-Module AzureAD.

Connected and authenticated to our Azure AD tenant successfuly using Connect-AzureAD as can be seen below.


PS C:\Users\Administrator> connect-azuread

Account                 Environment             TenantId                TenantDomain            AccountType
-------                 -----------             --------                ------------            -----------    AzureCloud              xxxxxxxx-0599-4cd4-8... xxxxxxxx.onmicrosof... User


But when running the Get-AzureADPolicy I get the error that this cmdlet is not available as can be seen below.


PS C:\Users\Administrator> Get-AzureADPolicy
Get-AzureADPolicy : The term 'Get-AzureADPolicy' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ Get-AzureADPolicy
+ ~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Get-AzureADPolicy:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException


What am I doing wrong?

I urgently need to adjust the token lifetimes.

15 Replies
Ok so I found out that I need to install the Azure AD PowerShell v2 preview module which I did. Unfortunately I still get the error that the Get-AzureADPolicy cmdlet is not recognized. I can use tab completion on Get-AzureADP and also Get-Help Get-AzureADPolicy is working.

Which version of the Preview module you have, works fine here with Make sure you are actually loading the correct module, as when you have matching cmdlets between both (Connect-AzureAD is the same for AzureADPreview and AzureADPreview). For example, open a fresh PowerShell window, do a Import-Module AzureADPreview, connect and then try running Get-AzureADPolicy.

Thank you very much! I was not aware that I had to import the module. Hope this wil change in the future so that the module loads automatically when start PowerShell like the MSOL module does.

It does load, but you have matching cmdlets between the two modules, and the non-preview version takes precedence. Unless you load it explicitly :)

First uninstall using

UnInstall-Module AzureAD

then install the preview module

Install-Module AzureADPreview

Having same issue. If I import the AzureADPreview module only the same thing occurs, so its loading the AzureAD module in the background. You should be able to run both side by side for production.

Not happy.

I have the same issue.  The AzureADPreview module was working fine with (I think that was the version) but updated to 2.0.11 I get the same experience.  If I run Install-Module AzureADPreview, then run Connect-AzureAD, it loads AzureAD module and the Preview cmdlets can't be found...  I can't run Preview cmdlets anymore.

Fixed it by uninstalling all AzureAD and preview modules, then installing the AzureADPreview version like this:
Install-Module -Name AzureADPreview -RequiredVersion

This worked. Installing the AzureADPreview module was failing as there were too many conflicting commands with the AzureAD Module. Once I uninstalled AzureAD and then Installed AzureADPreview (latest version then everything worked as expected. Thank you

Updated to the latest AzureADPreview Module ( and it worked fine for me.

This worked for me. I had a new Win10 laptop and installing the preview (v2.0.2.5) would work but Get-AzureADPolicy didn't.


I just had to run "UnInstall-Module AzureAD" in a fresh elevated PowerShell console and then the preview cmdlets worked perfectly




Hi Vasil,

when i am setting up for mapping policy on my Machin,


Somehow after all install module below is still not working - i am using with AzureADPreview

Get-AzureADPolicy is not recognized as the nameof a cmdlet.........


In order to have both AzureAD and AzureADPreview installed, but decide to use one or the other, you can use this: AzureADPreview\Connect-AzureAD to use preview instead of normal.


At the moment I have the same issue.


I tried multiple version of AzureADPreview, removing AzureAD module and many other combinations but the command is still not found.


Screenshot 2021-11-18 at 10.58.59.png


Related issue:

@Benoitt Use below command and it works


Install-Module -Name AzureADPreview -AllowClobber


and run Import-Module Azureadpreview before running policy commands