Microsoft Entra Suite Tech Accelerator
Aug 14 2024, 07:00 AM - 09:30 AM (PDT)
Microsoft Tech Community

Azure AD Connect -- Attribute Value Must Be Unique

Copper Contributor

-- Updating from my previous message --


I managed to get syncing attempts happening by removing the group filter.   
As my test group, I made a special OU for the test user and am applying the sync only to this OU.

 

I am now a bit further, but stumped again.
Both AD accounts and AAD accounts are pre-existing:

AD Account:   j.smith@domain.com   (actually a .local account, but UPN added to AD)

AAD Account:  john.smith@domain.com

When the sync happens, I am getting "Error:  Attribute Value Must Be Unique"

Looking deeper at the error, it is mentioning the error is in relation to the ProxyAddress.

 

I have already defined the following in AD for the j.smith user:

email (General Tab):   john.smith@domain.com

Proxy Address (Attribute Editor):  SMTP:john.smith@domain.com

 

this does not seem to help though.  I have tested also by removing Proxy Address and still no go.

 

any thoughts?

2 Replies

Fixed this item.

The issue was the test account (my account) was a Global Admin in AzureAD.   I needed to demote the account to user account first, make the sync, and then re-enable global admin for my account.

I had the same issue. My scenario is:

Account Name in local directory: John Miller

UPN: Email address removed and 

mail: Email address removed

I synched the object with the attribute mail because I won't the user's use the mail how to login for different services.

When I synched an Object that already was in AAD, I obtain the same error: Error:  Attribute Value Must Be Unique

I tried to put in the local directory the attribute mail and the acttribute proxy and than I synched again but first I deleted the new object created in the AAD. Remember to erase the object also in the deleted users in AAD.

 

@Astromechs