Microsoft Entra Suite Tech Accelerator
Aug 14 2024, 07:00 AM - 09:30 AM (PDT)
Microsoft Tech Community

ADFS - Unable to log on with UPN

Copper Contributor

Hi All,


In our development environment we have ADFS 3.0 servers authenticating federated users. Recently, users have been unable to log on using their UPN. SamAaccountName works without issue. For information the domain and upn set up is as follows:


The internal domain is

Users exist in the child domain "" but have a their UPN changed to


When signing into Office 365 or via ADFS theya re able to use their samaccountname but using the UPN gives an incorrect username or password error.


We see the following error in the ADFS logs:

Token validation failed.

Additional Data

Token Type:
%Error message:




If they attempt to use the ADFS password change page I see the following error in the logs:


Password change failed for following user:

Additional Data


Device Certificate:

Server on which password change was attempted:
Error details:


Any ideas what might be causing this?







13 Replies

You most likely need to adjust the claims rules to pick up the changed UPN format.

Can you elaborate a little Vasil? The authentication fails completely and claims are not released. The ADFS forms authentication page just rejects the password unless you use the samaccountname format.  our production environment is essentially the same and we dont have a similar issue so its quite puzzling.

Right, seems I've misunderstood the issue then. Your first post listed an "token validation error" event, which is generally generated *after* the user has successfully logon to the AD FS server. If the user is not even able to pass the login prompt, I'd suggest checking the event logs for any 4625/4624 entries related to that user and more specifically looking at the netlogon error ("status") therein.


@David McAllister 


Hi David


DId you come right here? I saw something similar many years ago.. You might need to alter the claims to support the multiple UPN suffixes. Did you set up the ADFS with the AADConnect wizard? I'm assuming the new UPN name space is federated and you are using it for Azure/O365

Currently we facing the same problem as your, can you share with me how you have fixed?



Can your users not login with their UPN's or are you having issues with the Password Reset URL in ADFS?







The user can not login with their UPN's and  gives an incorrect username or password error.


But they are able to logon with SAMAccountname (domain\username) format.






Has this never worked or has it suddenly become a problem? Have you recently changed any users UPN's in the company?




It never worked for child2 and no UPN changes


below is our scenario  - Child1 was promoted some time ago before we implemented ADFS , both users under parent and child1 are able to logon with same UPN ie. “”  -Child2 was just promoted , UPN was configured same as parent and child1 but unfortunately user under Child2 cannot logon with UPN)


PS: We only have one UPN domain 





So we are talking about 3 Active Directory domains 1 parent and 2 child domains with one UPN namespace stretched across them?


Yes, that's right



I'm busy sending you a private message...



Did you come right?