Unable to retrieve user photo from Azure AD profile

New Contributor

Hi,

 

We have created several users in an Azure AD tenant and since today we cannot retrieve the user photos via Microsoft Graph requests and also the user photos are not shown in Azure Portal neither we can update the photos. This was working correctly a few days ago.

 

Any help will be appreciated.

 

Thank you.

 

When requesting: 

 

https://graph.microsoft.com/beta/me/photo

https://graph.microsoft.com/beta/me/photo/$value 

 

We are receiving the following error response:

 

 

 

{
    "error": {
        "code": "AadGraphAuthFailed",
        "message": "Exception of type 'Microsoft.Fast.Profile.Core.Exception.ProfileInternalServerException' was thrown.",
        "innerError": {
            "date": "2021-03-01T12:28:24",
            "request-id": "50804d78-04bb-40c1-bbc7-49a2096733df",
            "client-request-id": "e429a97c-1457-dbdd-96c6-9afca4d726a9"
        }
    }
}

 

 

 

3 Replies
Works fine here, if you are still having trouble best open a support case.
Hi Vasil, Thank you for you reply. We are still getting HTTP 500 "Exception of type 'Microsoft.Fast.Profile.Core.Exception.ProfileInternalServerException' was thrown.", We will try to open a support case. Best regards

@josendf 

@Vasil Michev 

Hi, how did you got this working? or anyone else know?

 

Im using Flutter and when i try with the access token from Graph Explorer that starts with "EwCAA8l6BA..." Not a JWT Token i guess.. It Works. But the getAccessToken() from library aad_oauth; returns a token that starts with "Ey".. JWT token. It works with: https://graph.microsoft.com/v1.0/me/

But not with https://graph.microsoft.com/v1.0/me/photo/$value

There i get: 

 

 

 

 

 

 

{
    "error": {
        "code": "AadGraphAuthFailed",
        "message": "Accessing service failed.",
        "innerError": {
            "date": "2021-11-07T11:54:42",
            "request-id": "c39r14a4-e6b4-301c-bd44-ear13c24881d",
            "client-request-id": "c32f14a3-e6a4-102b-bd34-ecf12b24886d"
        }
    }
}

 

 

 

 

 

 

z0m1x_0-1636288411396.png

 

z0m1x_1-1636288548978.png

 
 
 
The other one works, that starts with "Ew" Same as in Graph Explorer

z0m1x_6-1636288711208.png

 

z0m1x_8-1636288781293.png

 

Anyone?