Azure AD account suddenly demanding Two Factor Auth Which Doesn't Work

New Contributor

I created an Azure account earlier today as I am studying for Azure certification. All went well for several hours, but stepped away for lunch and was timed out.  Cannot get back into account because it is demanding 2FA using the Microsoft Authenticator app which never once has worked for me. Two years ago I had our InfoSec group delete the requirement after I showed them my problems and pulled up thousands of help desk tickets with the same problems.

Tried it again, and of course it doesn't work.

Why did the Azure AD suddenly revert to 2FA?
How do I get into the account to kill that requirement as there is no Azure support for free accounts?

2 Replies
As of this morning, I can get in using Chrome with no problems. I hadn't tried Chrome yesterday. Logging in to respond here - Communities with Android Chrome, I was challenged to use Authenticator, but also offered password only. My account doesn't have two factor authentication attached to it. On Edge, I'm still locked out. Later today I will export bookmarks and then uninstall, then reinstall Edge. Very strange stuff!