Windows 11 Explorer preview pane fails to preview some documents and not others on SMB share

Iron Contributor

Each month I run a saved search on an SMB share to find some XL documents. In the results windows in Windows 11 Explorer, I have always been able to select the files in the results window and preview the files in the preview pane, without any issues.


Recently though this has not been working. I run the same search on the same SMB location and get the expected list of XL files. However, if I click on the files I can see the preview of only some of the files. So, the previewer is working and the file associations are working. However, the only way I can see a preview of one of the XL files is to open it, click on the button that says "Enable Editing", close the file and only then can I see the file in the preview. If I open the file and don't click "Enable Editing" I am still unable to preview the file.


Just as I finished typing this article I had a brainwave and just checked the Office Trust Center settings and found the problem.


Yep. A recent MS Office update fried the setting I had for my SMB share to be a trusted location.


Thanks for another great "security fix" from Microsoft!

0 Replies