Outlook View in Browser Ignores Default Browser and Opens IE When Office 365 Doesn't Even Support IE

Brass Contributor

With the new Edge I was hoping to finally see the back of Internet Explorer and whilst Microsoft have dropped support in some areas there seem to be key places where it is still the one that is selected and it is still installed in the latest versions of Windows 10 when even Edge legacy is not anymore.

 

If you are in Outlook and you click the bar at the top of the email that says:

"If there are problems with how this message is displayed, click here to view it in a web browser".

 

You would expect this to open your default browser but it always opens IE no matter what is set. This still happens in the most recent version of Office 365 and no matter whether you set as the default via either group policy or the user. A software restriction policy doesn't work either as just leads to an error.

 

So what happens then is the email doesn't display properly, the link at the top of the email opens IE at which point it may display ok but then clicking a link in the email takes the user to the website in that browser which then doesn't work correctly as doesn't support IE.

According to Microsoft, Office 365 doesn't even support IE yet it still picks it as the browser to use in this instance. This leads to about one support call every 2 weeks.

Other Microsoft software does too such as when debugging in Visual Studio but at least there is an option to change this.

 

I don't know why everything can't just use the default browser as presumably this is the one the user wants to use if set as such.

18 Replies

That's an OS level setting, basically you need to change the associations for .MHT/.MHTML file types. Not all browsers expose this as supported file type though, so you might end up needing to change it directly in the registry.

@Vasil Michev Thanks I have tried this as didn't realise it was linked to those file types.

Whilst it does switch the browser, it opens them in plain text indicating Edge does not understand this format:

 

Edge 1.png

 

Results in:

 

Edge 2.png

 

Is there a way to get Edge to understand emails or is support coming in the future?

 

Thanks

Robin

It looks like support for doing this in Chromium was removed a while back...

Totally flabbergasted when this just happened to me. I'm sure I saw a note that IE was dead over the next year.

the MHT and MHTML settings can only be changed to Edge, not any other browser.  I use Opera and Firefox so what is the fix for those browers (I have Opera set as depault browser)?

@Malcolmx I wonder if the reason modern browsers don't support this format is because it is so outdated and followed web design principles from about 20 years ago when you had to hard-code styling and use HTML tables and fixed widths. Web technology has moved on but Outlook HTML rendering remains in the past even on the most recent Office 365 versions.

Everytime I have to create an HTML email such as for password resets it reminds me how old-fashioned it is. Perhaps IE is the only browser that still understands this as that too is from the past and should have been replaced years ago.

The best solution would be for Microsoft to switch to a newer rendering format so HTML emails could use responsive layouts and modern standards.

@Robin Wilson Thanks for this. I hope someone is following this thread. I keep finding IE being started by office apps: 

in the Outlook Signature "get signature templates" 

In Outlook again when adding a gmail account. 

Even on a new install of Windows 10 and Office 365 new download of the apps, I find these issues. 

@Robin Wilson  Can you believe it is more than a year later and this is still not fixed!  This is totally UNACCEPTABLE

It is a bit bad considering there is no solution and the current version of Microsoft Office tries to use another Microsoft tool that is no longer supported. Sure they are having lots of meetings about how to fix it, hmm.

@Robin Wilson  It is depressing that Microsoft does not support modern browser displays within Outlook natively and now the view in the web browser does not work at all.  For a while I got it work with all mentioned hacks but in the last few days after the most recent update it does not work at all again with all the possible settings still in place.  Now it gives a file not found message.

 

Microsoft you are really messing this one up bad.  Help the world out?

It does feel this has just been missed. From an IT Support point of view it does lead to a few support calls a month at least but there is no solution.
Going to get worse as IE starts disappearing from desktops and Microsoft's own apps keep creating files that can't display in any browser including their own.

Is there a fix for this issue? I've resorted to restarting the app several times and somehow it picks up my login credentials. However, it doesn't last and prompts for reentry several times a day. I'm using 2 different Outlook accounts in this instance.  When this happens, the popup window defaults to IE. I have already reset the MHT and MHTML extensions to Edge. This is definitely a bug, so there should be a fixpack available by now. Any updates? 

I'm still having a related issue, specifically with the Smartsheet for outlook plug-in, the sign in times out frequently, but clicking 'log in' in outlook (2016) brings up a new window that I can't do anything with except close in IE and it says unsupported browser, so I then have to log into the desktop site and sign into the plug in there and then go back, super annoying. I went into my system settings and changed as many default programs as I could off of IE and to Edge or Chrome, and same issue. What is it pulling IE from?? They need to fix this and let it run off the system program choice, since them forcing IE is weird when it's going away essentially. This is the only thread I've found talking about this exact issue, but it must be more people having this issue.

@Robin Wilson I found a solution that fixed this issue for me.

This article describes it well (https://www.msoutlook.info/question/view-message-in-browser-only-shows-html-code), but I just had to change a setting in Edge that enabled a sort of IE compatibility mode.  I verified that it is now displaying "view in browser" emails via Outlook 365 properly in Edge, instead of just showing the raw code.  I hope that solves it for you and the others on this thread too.  It has been broken for years for me until I finally just found that solution.

Thanks - this works. Enabled IR compatibility mode in Edge settings
Same still happens in Outlook 2021 Desktop version , I see lots of people discussing these issues but I don't see Microsoft addressing any of them and its nearly 2024 ?