O365 Online Archiving Not Working


We migrated users to O365 last week.

And for the most part everything is good.  All using E3 licenses

But one users mailbox is not archiving.


I've confirmed that is OWA for the user

right clicked on user name and Assigned Policy is what we configured

right clicked on folders and they are set to use parent

Can see the in-place archive folder but nothing is in it


From Powershell

Get-mailbox user | RetentionPolicy Set, ArchiveDatabase Set, ArchiveGuid set

Run Start-ManagedFolderAssistant a few times


From Security and Compliance

Archive enabled


But still nothing is moving to the archive

12 Replies

Thanks I managed to fix the issue.  even though there is no security or compliance policy enabled.

when I checked the mailbox settings I found the RetentionHoldenabled was $true for effected user but no others

Interesting. You might be able to discover why this mailbox has that property enabled by looking at the Office 365 audit log...

yes.  especially since the ecp wasn't showing a hold

I had the same EXACT symptoms you experienced just now, and your resolution fixed the issue.  Still not sure how RetentionHoldEnabled got set to $true.


Bump for saving me!!

This saved me today! Thanks!

had same issue when trying to enable in-place archive for a user. realised that using the Office 365 PST import utility to bulk import mailboxes automatically enables retention hold, thus you need to change it to false for in-place archive to start working!

I had the same issue this week and thanks to you all I also found the problem was due to the mailbox having the retention hold enabled even though it showed disabled in EAC. Can confirm this site had used the Office365 PST import utility too.

To check the mailbox:
Get-Mailbox "Michael Allen" | Select RetentionHoldEnabled
To disable retention hold:
Set-Mailbox "Michael Allen" -RetentionHoldEnabled $false
Start the Managed Folder Assistant
Start-ManagedFolderAssistant -Identity "Michael Allen"

@BishopstonIT @slawrance Quite right on the PST Import here's the documentation.
After PST files are imported, the retention hold setting for the mailbox is turned on for an indefinite duration. This means that the retention policy assigned to the mailbox won't be processed until you turn off the retention hold or set a date to turn off the hold. Why do we do this? If messages imported to a mailbox are old, they might be permanently deleted (purged) because their retention period has expired based on the retention settings configured for the mailbox. Placing the mailbox on retention hold gives the mailbox owner time to manage these newly imported messages or give you time to change the retention settings for the mailbox. See the More information section in this topic for suggestions about managing the retention hold.
This help solve my issue!
Thanks a lot.
This was a great save for me as well. Our older users ported into M365 from on-prem Exchange for the most part had PST's imported in for their legacy local archive content. These older users were all stuck, in terms of their online archive not reflecting the data retention policy. Problem solved. Thanks for the tip!

Hi guys,


I have the same problem.From outlook(account 365) i make import the pst.

After that I enable the arhive but didnt work.Its start for one moment but it stoped.The account not receive or send email.The link from ITpro i didnt find something.So what can i do?


Thank you@David Wilson