HCW8078 - Migration Endpoint Could not be created (Exchange 2010)

New Contributor

Hi all,


I'm trying to setup a hybrid with Exchange 2010 (14.3.513.0) and I get the error "HCW8078 - Migration Endpoint Could not be created" at the end of the Wizard.


If I run Test-MigrationServerAvailability from the EOL Powershell I get the following error:


RunspaceId : 537c3401-d723-40f8-a9c9-9a82eeff5fbd
Result : Failed
Message : The connection to the server 'remote.xxxxxxxx.com' could not be completed.
SupportsCutover : False
ErrorDetail : Microsoft.Exchange.Migration.MigrationServerConnectionFailedException: The connection to the server 'remote.mydconsulting.com' could not be completed. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemoteTransientException: The call to 'https://remote.xxxxxxx.com/EWS/mrsproxy.svc' failed. Error details: Access is denied.. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemotePermanentException: Access is denied.
--- End of inner exception stack trace ---
at Microsoft.Exchange.MailboxReplicationService.MailboxReplicationServiceFault.ReconstructAndThrow(String serverName, VersionInformation serverVersion)
at Microsoft.Exchange.Connections.Common.WcfClientWithFaultHandling`2.<>c__DisplayClass4_0.<CallService>b__0()
at Microsoft.Exchange.Net.WcfClientBase`1.CallService(Action serviceCall, String context)
at Microsoft.Exchange.Connections.Common.WcfClientWithFaultHandling`2.CallService(Action serviceCall, String context)
at Microsoft.Exchange.MailboxReplicationService.WcfClientWithVersion`2.CallService(Action serviceCall, String context)
at Microsoft.Exchange.Migration.MigrationExchangeProxyRpcClient.CanConnectToMrsProxy(Fqdn serverName, Guid mbxGuid, NetworkCredential credentials, LocalizedException& error)
--- End of inner exception stack trace ---
at Microsoft.Exchange.Migration.MigrationEndpointVerifier.VerifyConnectivity(MigrationEndpointBase endpoint)
at Microsoft.Exchange.Management.Migration.MigrationService.Endpoint.TestMigrationServerAvailability.InternalProcessEndpoint(Boolean fromAutoDiscover)
TestedEndpoint :
IsValid : True
Identity :
ObjectState : New


I have confirmed ports are opened on the firewall, in fact, I can see the connection coming in through port 443.


I've also confirmed that the MRSPROXY is enabled, with Basic, NTLM, WindowsIntegrated and WSSecurity authentication set to true.


I can access https://remote.xxxxx.com/EWS/mrsproxy.svc' from outside and get the prompt to enter the credentials, which work.


I tried resetting IIS.


I also found that the computer object had the adminCount attribute set to 1, and that was part of the Cert Publishers security group. I removed the object from that group, set the adminCount atribute set to 0, then restarted and the attribute was set back to 1 automatically.


Any ideas?







9 Replies



I am having exactly the same problem.  It was working about 2 weeks ago, I added the MRS Proxy at that time, performed a test migration without issue, then waited for the customer to be ready to start migrating, then when we were going to do the first migration batch, it stated that our migration endpoint was not functioning.  Now I cannot get it to add again.  I have done the same steps and I see this adminCount set to 1 on my server too.  I removed the policy certificate authority from the server and removed it from the Cert Publishers group as well.  Still not able to add a migration endpoint on this server.  Have you had any success in resolving this?

Still no success. I think the last patch we all had to install broke the hybrid, because we have another client with Exchange 2010 which was running smoothly for some time and it broke a few days ago, we think, after installing the patch. That one was easy though because all mailboxes were already migrated so we could get rid of the hybrid, but in this case we haven't even started!
Exactly... service issue. Waiting until tomorrow for the next update... Hopefully they will have it fixed.
Same issue here trying to implement a hybrid on an Exchange 2010 server. Has anyone had any success?

@cjm-1993 just wait until the service health issue has been fully resolved and it should work normally again.  Watch this advisory for updates:




Hope this helps!

FYI, I've just tried to run the Hybrid Wizard again and it completed successfully.
Unfortunately, mine has not. Still waiting on all of the servers in 365 to be patched today. Mine must be on one of the last ones being patched or I have something else wrong too...