AutoUpdate for Mac is not working

Iron Contributor

Microsoft Office AutoUpdate for Mac is not working. The issue exists since several days. The manual update to the latest version works flawlessly, only the automatic updates no longer work.
Error message: "Updates are temporarily unavailable. Please try again in a few minutes."

I don't use a proxy.

I first completely uninstalled the Autoupdate and removed all the related individual files.
Then I installed the newest version 4.35, and the same error occurred as before.
Then I completely uninstalled it again and installed version 4.4. Then the auto update program worked again (as before). However, it wanted to install further Autoupdate versions, first 4.7, then 4.9 and then finally 4.35. And now comes the same error message.
Is it a bug in the current version?

30 Replies
best response confirmed by AtanasM (Iron Contributor)

If you are seeing the Update Error (updates are temporarily unavailable) message in Microsoft AutoUpdate in Mac OS on MAU v4.35.21051700, please try executing the below commands in a terminal and check. This solution was shared by Microsoft support (Thank you Keno) and it worked for me.


launchctl stop /Library/LaunchAgents/

launchctl unload -w /Library/LaunchAgents/

launchctl load -w /Library/LaunchAgents/

You may see errors for some of the commands, especially the unload cmd, but thats fine.

After executing all the commands above open Microsoft AutoUpdate and click retry. Try clicking retry a few times, if it doesn't work the first time.

Hope this helps.

I'm facing a similar problem:
The Microsoft AutoUpdate app for macos keeps bouncing on my Mac but does not work. The only option to get out of the loop is to force quit MAU.
I have MS Office 16.50 installed on my MacBook Air (M1, 2020) with macOS 11.4.
Any advice?

@mctosima93 Thanks, this worked

@mctosima93 Thanks it worked!

This worked for me as well.



I tried and it didnt work for me, It frustrating

Would you mind giving me the steps for these instructions? I copied and pasted the into the terminal, but I can't get it straight?
Try to find them manually.


I tried the manual process but getting an input/output error -- 

Unload failed: 5: Input/output error


I am getting Unload failed: 5: Input/output error on the unload step. Any ideas?
This worked for me, thanks!

Thanks, this worked for me. @mctosima93 

@mctosima93 This worked like magic, thanks!

I've also just encountered this error and found that updating each app one at time worked for me. Seemed that instead of downloading the update file, the updater pulled the whole download. Fixed it for me anyway

@mctosima93 I've applied the fix you suggested and it seemed to work, but the AutoUpdate stuck in the installing processScreen Shot 2022-01-28 at 10.03.40 AM.png

@Fareed Fattal


I have the same problem ! Did you find some tips to reset it or clean the cache?

Unfortunately, not. I've deactivated my Office 365 on the Mac and moved on!

This page has troubleshooting tips:


I solved my problem using the link at the bottom of that page to "download the installer for the latest version of AutoUpdate"