This page is having problems

Brass Contributor

Hello everybody!

I started using Microsoft Edge Dev some months ago and everything went smoothly until today: I turned on my laptop, opened Edge Dev and noticed that it is not working anymore at all.


Any page that I try to open (even the welcome tab) doesn't load and moreover the only two extensions that I installed (uBlock Origin and Norton Password Manager) are crashing.

I would like to check the log file (if any) in order to understand a little bit better what's going wrong under the hood.


I'm using Windows 10 Pro 1903, unfortunately I can't provide the Edge Dev version since the "about" tab is not working. Trying to download and run the latest installer from the web did not help.

56 Replies

@paolot I am seeing exactly the same problem. Win10 1809 Enterprise in my case.


Same here, running fine for weeks then suddenly the same problem - no pages (not even "Edge" pages, such as settings) will load, and all extensions crash. This happens with both Edge Dev and Edge Canary, and I've tried reinstalling both but the problem persists. I'm running Windows 10 Pro 1809 x64.


Starting Edge with the '-no-sandbox' switch seems to workaround the issue, but doesn't seem like a proper resolution?

@Peckmore thanks for sharing, using that flag makes it working also for me. That's obviously not a solution but for sure a precious workaround at the moment! :)
same problem here, Win 10 pro 1903, all tabs crashing. I have the adblock extension which is crashing but I also can't access the extension page to try disabling it

@paolot I'm having the same issue on 64-bit Windows 10 (1809), it might be related to an open Chromium issue


best response confirmed by V-FRROME (Microsoft)

@RetroChrisB thanks for sharing. Reading the discussion about that issue I got rid of the previous flag ("-no-sandbox") and changed to "--disable-features=RendererCodeIntegrity" since that should be a little bit more secure.


I was having the issue a few days back with Edge Canary, but it's fine now after one of their daily updates. I've had it happen in Chrome Canary too and the same thing...usually by the next day update (or second next day update) it's fixed. Sometimes for whatever reason it carries into Dev. As others said there can be a specific reason or Windows reason for it happening (I don't know as Canary is working fine for me now, an I'm not on the Dev side of things). 


You can also see if the same bug happens in Chromium:


(Keep in mind that Chromium is not meant to be used as an everyday or regular browser as it doesn't have auto updater or any updater except manually installing it everyday, and it lacks important codec that isn't built into it to run certain applications. So stick with Edge Canary/Dev/Beta for that, but it's good for testing to see if a bug is in the original source or for analyzing  to see if an crashing issues found in the later versions like Canary and Dev are happening in the original trunk version).

Same issue here! Versão (Compilação oficial) canary (64 bits)


Windows 10 pro 1903 @paolot 

@tharosfire @paolot @Anthony @RetroChrisB @Mark Heath 


Thanks, everyone for reporting this issue.


I have reported this problem to the engineering team.


I'm curious if it's only affecting specific extensions, could you all please list an extension or two you where using?


Thanks for your patience,



I've just got Adblock Pro, but only one out of three computers (all with the same extensions) has the problem on the latest version of dev channel, so I don't think its to do with the extensions themselves. The --disable-features=RendererCodeIntegrity flag fixes it for me on the computer that is failing.


In my case the Chromium team think it's a known incompatibility between Symantec Endpoint Protection 14.0.3929.1200 and renderer code integrity. I am using that version of Symantec Endpoint Protection.


I don't currently have any extensions installed

@RetroChrisB interesting, indeed I'm using Symantec Endpoint Protection 14.0.3876.1100, just curious if it's affecting only people with this antivirus.

@RetroChrisBI can see a correlation here too.

"--disable-features=RendererCodeIntegrity" solves the problem.

We're using Symantec EndPoint Protection on our PCs too, version 14 (14.0 RU1 MP2) build 3929 (14.0.3929.1200) on Windows 10 Enterprise 1709 (16299.1268) 64 bits.

@paolot indeed, we are using SEP as well, version 14 (14.0 RU1 MP1) build 3876 (14.0.3876.1100)

I came in this morning to the same issue. We are running SEP 14.2.1031.0100.


Creating a shortcut with --disable-features=RendererCodeIntegrity is a working workaround for me as well.


Having the same problem on a work PC - we are using SEP as well.

I am having a similar but intermittent problem as well, both on MacOS and PC.


In my case, tabs will randomly redirect to the "this page is having a problem" error page, either immediately when opened, or a while after they are launched. No real pattern, and some tabs never have the issue.


I do not use Symantec Endpoint Protection in any capacity.


Using this list of extensions:

  • 1Password X Beta – Password Manager
  • Alternate Player for
  • Open In IINA
  • Reddit Enhancement Suite
  • Shut Up: Comment Blocker
  • Stylus
  • Tampermonkey
  • uBlock Origin
  • uBlock Origin Extra
  • Video Resumer

@V-FRROME I did a report through the browser, was erroring on Cisco WebEx (v1.5 & latest) plugin from the Google store, the only one installed. However even with it disabled I still had the issue. Had the same issue on the Canary build, but Beta being a bit older remained fine.


Alternate to the flags, on Win10 if you put the browser in Win8 compatibility mode it works fine. 

@paolot  I got the same error

1 best response

Accepted Solutions
best response confirmed by V-FRROME (Microsoft)

@RetroChrisB thanks for sharing. Reading the discussion about that issue I got rid of the previous flag ("-no-sandbox") and changed to "--disable-features=RendererCodeIntegrity" since that should be a little bit more secure.


View solution in original post