You don’t appear to have an active Azure subscription

Copper Contributor

I have free trial subscription. While configuring pipeline, i was trying to select docker, but upon selecting it saying "You don’t appear to have an active Azure subscription". I've added myself to endpoint users too as per azure support agent suggestions, but still facing same issue. Please do the needful.

7 Replies

@harsh740 I tried MSFT Azure support, they suggested to reach out to Azure devops as this issue related to azure devops.

 

@Kidd_Ip I've tried your suggestion, still no luck. 

Hi, are you able to resolve this issue. I am facing same issues, i tried all aspects like clearing cache, modification of tenant properties, subscription status check, login through incognito mode. Please suggest how can i get it resolved.

@Andlo2023 

 

This FINALLY solved it for me:

 

In the azure portal, go to "Azure Devops Organizations" and then switch between Microsoft Account and Default Directory, and back to Microsoft Account. 

 

diegomggp_0-1702383342699.png

 

diegomggp_0-1702383705479.png

 

 

 

i cant believe this worked, thank you!