Azure DevOps Release Pipelines have stopped not being able to download Artifacts

Copper Contributor

Our release pipelines stopped working as of this morning can no longer download Artifacts that were produced by the related build pipeline.

The same build artifacts is gets download for other staged like dev in same release pipeline, but not working with QA stage.

What value cannot be null? there is a built artifact there in the system I can see it and the release has a valid link to it.

Error logs are attached below:-

6 Replies


Having the same issue.  version 1.189.1 worked but V 1.189.2 fails (not sure if that is relevant).  If I rerun a previously working release it will fail too. 


I changed agent pool specification from 'vs2017-win2016' to 'windows-2019' with no success.


anyone else seeing this?

@hereforthebeer I have the same issue since this morning. Still figuring out what is wrong..

Hi, i had the same issue today. In my case the solution was deployed to a VM and i had to update the vsts agent running on the target machine.

In azure devops,Go to Pipelines -> Deployment groups. Click on the 3 dots in front of the name of the group and select "update targets".

Now go try the deployment again, it should work.

@NotABlogger, thank you, had similar issue today, updating the agent version resolved this.

@NotABlogger Thanks - same issue today, your suggestion fixed it.

Same issue here. Agent version 2.160.0