Microsoft Remote Desktop multi screen Issue for M1 MacBook Pro

Microsoft Remote Desktop multi screen Issue for M1 MacBook Pro
4

Upvotes

Upvote

 Jan 14 2022
5 Comments (5 New)
Closed

Hi,

Since the last 2022 update of Microsoft Remote Desktop, 10.7.4 with the new 2021 MacBook Pro 14", the resolution option "Use all monitors" doesn't works anymore.

 

Can you fix it please, I need this option for work.

Comments
Occasional Visitor

Same issue. If I unselect "use all monitors" I get normal resolution on a single monitor. When the (previously working) "use all monitors" option is selected, not only do I only get one monitor, it shows at a very low (unusable) resolution. (also on a 2021 MacBook Pro 14")

Microsoft
Status changed to: Active

Hi @Ueihtam ,

Thank you for letting us know, this feedback will be shared with the engineering team and we will provide you updates!

Microsoft
Status changed to: Tell us more

@Ueihtam @mrosernthal 

A new beta release came out on Friday: 

In this release we've addressed display configuration failures that occurred when using the 2021 MacBook Pro 14" and 16" models with multiple monitors. Specifically, we handled scenarios where external monitors were positioned above the MacBook display. In addition, we addressed a crash on early versions of macOS 12, and fixed customer-reported smart card and folder redirection issues.

Thanks to everyone who reported bugs and worked with us to diagnose and fix issues. If you encounter any errors, you can contact us via Help > Submit Feedback.

 

Please download the beta at aka.ms/rdmacbeta and let us know if this issue is continuing!

Occasional Visitor

Thanks a lot, guys! I can confirm a new beta is working with 2 monitors on MBP 14" 2021 with M1 again, I got back also a good resolution (previously it was working only on 1024x768 or something else what looked worked on retina than the screen on my historic calculator from primary school).

 

Only problem was the app crashed during I was trying to import my 32 connections from RDP files. After I run it again, it's working great. 

 

Thank you so much again!

 

Kejml

Microsoft
Status changed to: Closed

10.7.5 in App Store has fixed this problem