Copy / Paste stops working after long RDC sessions (Mac)

Copy / Paste stops working after long RDC sessions (Mac)



 Nov 09 2021
7 Comments (7 New)

When working for hours with a RDC on a Mac, copy / paste stops working between host and remote computer. Remote Desktop for Mac then needs to be restarted to restore the feature.


I get errors about post flooding. But this is my first message ever here. :o

Status changed to: Active

We will investigate this issue and keep you updated.


Status changed to: Tell us more

Hi MRisberg,

There is a server-side issue that causes a hang up with clipboard in remote sessions, we are planning a fix for this issue. In the meantime, an immediate solution is as follows: end the RDPclip.exe process which will automatically restart and resolve your issue. Please let us know if this helps. Thanks


Thanks for the feedback. It's good to hear that this is being worked on.


This RDPclip.exe process, is it found on the server end? Can't see a process by that name on my Mac, with or without the extension .exe, while running Remote Desktop.

Status changed to: Tell us more

Hi @MRisberg ,

This RDPclip.exe process, is it found within the Remote Desktop aka the server end. Therefore, in the Windows OS on your Remote Desktop go to Task Manager -> Details -> scroll down to rdpclop.exe -> select End Task

Occasional Visitor

I have been having the same issue for over a year. Finally got here somehow as this is not visible on google.  


I tried killing rdpclip.exe on the server but it did not restart.

Status changed to: New