Yammer online "your reply could not be posted" error

Regular Contributor

Hi Everyone,

I think this is a bug that has been introduced recently into Yammer.

 

  • In Yammer website
  • When a user clicks on Notifications
  • Then clicks "view conversation" link
  • Then enters text in the "Write a reply" box
  • AND also tags a user e.g. @BobBrown 
  • then clicks Post
  • They are shown a "Your reply could not be posted" Popup alert notification
  • The reply isn't posted.

If the user goes to the group, finds the same post, and enters text in the "write a reply box" that includes an at mention of a user, then clicks POST they DO NOT get the error and their reply is posted.

 

In the Goolge Chrome console I see an XHR 400 error posting the reply

Once the user has gone to the group, and posted a reply if they go through the process above with another notification, they get no error.

 

It seems like creating the first reply in the group context, connects something up so that when the user clicks Notifications then "view conversation" that connection or cookie or whatever persists and the user can work without error.

 

Any one else seeing this ?

Been happening here for about 2 weeks I think. Only been able to narrow down when it happens today.

 

9 Replies

We were getting similar errors throughout our network during one day last week, but it cleared itself up by the end of the day.

 

@Dorje McKinnon 

@Larry Glickman 

Many thanks for letting me know I'm not going mad, and we're not on our own. :smile:

 

Unfortunately we're into at least day 5, possibly two weeks.

We do have work arounds staff can use. It would be good if one of the Yammer team could let us know if there is a fix coming through the system some time soon for our tenant.

@Dorje McKinnon Best thing to do is to escalate to your Microsoft Support contacts.

Thanks @Kevin Crossman , I think you're right.

I've got a couple of open jobs with them at the moment, so I'd hoped to get a sense of how prevalent the issue is before logging it.

 

D

 

I got the same error.

Only difference from the repro steps above was that I searched for a post instead of coming from a notification.

Scrolling to the post and then posting your comment is a viable work-around.
Yes, another one who is experiencing the same issue which was raised a couple of weeks ago for the first time internally also. We've raised a support case with Microsoft and am trying to confirm whether it's been acknowledged as a bug, something unique to our configuration/authentication or something else altogether. Would love to hear from people on if they've raised a case with Microsoft as well - The preferred workaround here is to use the Yammer app as it doesn't seem to be affected by the issue and doesn't require having to remove any @mentions.

We have started to encounter this problem. Using the work around provided worked for the time being. Has Microsoft discovered the cause of this error? 

 

@Dorje McKinnon 

@JonesPT 

 

I've received an update from Microsoft that the Yammer Product Group has released a fix for this issue.  Initial tests seem to validate this, but still in the process of confirming.  Wanted to share the update for a broader uat pool :)

 

@Dorje McKinnon

 

@kesuvo83 

Many thanks for letting me know.

 @joelleichty  and @JonesPT  , have you seen this fix appear in your tennant's yet ?
I've just tested and it is working in my Tennant 
BUT

The @StaffName function doesn't resolve the person's name ...... which is an essential piece of functionality when I'm trying to welcome #joined new staff members .... [sigh]
Anyone in the #Yammer team able to let us know if failure of the @mention function is a BUG or expected ??