Yammer Bug: Unable to upload new jpg version uploaded via mobile app if you've changed the file name


This is a bit obscure, to be sure. When you've uploaded a .jpg from an iPhone to a Yammer post via the mobile app, it uploads with the file name Image Today at 12:40:01.jpg (with the colons). When you download that image, your mac or PC can't deal with the colons and changes the file name to underscores so it would be Image Today at 12_44_01.jpg. When you try to upload another version of this photo, it will not work because the filenames do not match. I tried changing the file name to a word - say Photo1 and then tried to upload a Photo1.jpg replacement. It will upload the image, but it will not complete the process and allow you to proceed. It just keeps saying "image processing". Is anyone else seeing this? Any work arounds? I've tried two computers (Mac and PC) and 3 browsers (Chrome, Safari and IE11), no luck. 

1 Reply

Not quite the same behavior, but also a "upload new version" bug, I think.

Today I pasted a screen shot (image.png) into a post, then after the usual "think after post" time, realized that I could make it better (by adding numbers!). 

When I tried to upload a new version of the file (same name or not), Yammer displayed a message "Processing file", but didn't.

I guess I can't upload a new version of a screen shot...I guess I can't upload a new version of a screen shot...