HTTP 403 when trying to retrieve topics and topic related messages from Yammer REST API

Occasional Visitor



We are currently facing an issue trying to retrieve message about topics or even topics themselves via the endpoints






When I replace the parameters by a valid ID and call the resulting URL, I just receive a HTTP 403 response.

This happens even just after retrieving a new token via MSAL. We can call other endpoints just fine. At the moment, only the endpoints mentioned above are causing issues.

I also logged in to Yammer (so I have a token cookie) and opened the URLs in my browser, to make sure that this is not a MSAL token issue.
This results in exactly the same error. I can retrieve messages by group just fine (/messages/in_group/:group_id.json), but the issue regarding topics and messages about specific topics still persists.


Do you know by any chance what might cause this issue? Thanks!




I noticed that the undocumented /tags/:Tag_ID.json returns the expected result.

But I can't figure out the respective endpoint for returning messages with a specific tag...

I was expecting something like /messages/about_tag/:Tag_ID.json but that returns just HTTP 404. I tried different combinations with the word "tag", but nothing works.

Is such an endpoint even available?

0 Replies