Macros Disabled but I want them enabled

Copper Contributor

I just started a new file in Office 365 and it automatically blocked my macros, even simple things that I have made myself to speed things up and which all work absolutely fine normally. I want to enable macros but no matter what I try, it won't enable them. I tried in the 'Trust Settings' and told it to allow all macros but that doesn't work. I tried looking in the file manager Properties but I don't get an option to change it there either.

Anyone got any ideas please?



3 Replies

@RobBarron I noticed this as well with the recent 22H2 update to Windows 11.  I don't know if you've installed that update or not.


All my macros were working fine in Office 365 until then, but now every document opens up with a security bar saying macros have been disabled, and every effort I try has no effect in allowing macros for any document whatsoever.

I've gone into Trust Center and added every possible Trusted Location for any document that I may use. Trusted Documents are enabled. Macro Settings, Enable all macros and Trust access to the VBA project object model are selected., which should mean that, duh, all macros are enabled.

The craziest thing is when I click on File-Info-Security Warning-Enable Content, the actual Enable Content is grayed out, so I can't select it.


I also occasionally get a confusing box when trying to run a macro from the macro editor itself.  I'm pretty sure it used to have an option to Enable Macros for This Session, but now it literally has the same identical two options of "Help me Protect My Computer".

@RobBarron Where do you now have the macros? If you want them to be available for use with all documents. put them ni a macro-enabled template (*.dotm) that you save in the Word Startup folder so that it will be loaded as an add-in

See my response to @RobBarron